summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <msvensson@shellback.(none)>2006-09-12 15:47:48 +0200
committerunknown <msvensson@shellback.(none)>2006-09-12 15:47:48 +0200
commitacd9f1bd69211e6dc85ec1386514818f487210bd (patch)
tree565f736e2e9e7cc12c7ec92a8fd2ec0df49a4817 /configure.in
parentbd8309cce6793352cebcf54459fa301eaab0b3b8 (diff)
downloadmariadb-git-acd9f1bd69211e6dc85ec1386514818f487210bd.tar.gz
Bug#14862 undefined reference to `isinf' on SOLARIS - strings/strtod.c
- Change the configure test looking for 'isinf' so the value returned from isinf is used. That avoids the call to isinf being optimized away. configure.in: Use the value returned from isinf so it's not optimized away by the compiler(i.e gcc 4.1)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b49dffcb59f..74aff4c6252 100644
--- a/configure.in
+++ b/configure.in
@@ -1946,7 +1946,7 @@ esac
# isinf() could be a function or a macro (HPUX)
AC_MSG_CHECKING(for isinf with <math.h>)
-AC_TRY_LINK([#include <math.h>], [float f = 0.0; isinf(f)],
+AC_TRY_LINK([#include <math.h>], [float f = 0.0; int r = isinf(f); return r],
AC_MSG_RESULT(yes)
AC_DEFINE(HAVE_ISINF, [1], [isinf() macro or function]),
AC_MSG_RESULT(no))