summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormtaylor@qualinost.(none) <>2007-04-17 18:12:43 -0700
committermtaylor@qualinost.(none) <>2007-04-17 18:12:43 -0700
commite208ce21de1310fb431073409d4ee68049d27c3f (patch)
tree438523cae033ef68fa7e983580138a5fc7dab8af /configure.in
parent99c5f418af1e2076b9f66624559f39288129c17a (diff)
downloadmariadb-git-e208ce21de1310fb431073409d4ee68049d27c3f.tar.gz
BUG#27769 - MySQL should include debian packaging dir
Replaced hardcoded sover reference with variable. Removed references to added manpages. --- BUG#27769 Cleaned up some things to make building the packages go a little smoother. --- debian/rules really does need to be called from the source root. --- Fixed two problems with the build caused by adding debian to the source tree --- Left off the debian/ prefix to the Makefile filter. --- BUG#27769 - MySQL should include debian packaging dir Changed substitution variables to match already existing autoconf vars. Generate debian/control and debian/defs.mk from autoconf now, since we run that to make a source package. --- Corrected incorrect variable name --- Renamed template files to have shorter names. --- Moved generation of debian/control to dist-hook so make clean won't eat it. --- A few final changes to make debs build from a source tarball dist.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c508fdfc580..bed74b06bd7 100644
--- a/configure.in
+++ b/configure.in
@@ -32,6 +32,9 @@ MYSQL_NO_DASH_VERSION=`echo $VERSION | sed -e "s|[[a-z]]*-.*$||"`
MYSQL_BASE_VERSION=`echo $MYSQL_NO_DASH_VERSION | sed -e "s|\.[[^.]]*$||"`
MYSQL_VERSION_ID=`echo $MYSQL_NO_DASH_VERSION. | sed -e 's/[[^0-9.]]//g; s/\./ /g; s/ \([[0-9]]\) / 0\\1 /g; s/ //g'`
+# Add previous major version for debian package upgrade path
+MYSQL_PREVIOUS_BASE_VERSION=4.1
+
# The port should be constant for a LONG time
MYSQL_TCP_PORT_DEFAULT=3306
MYSQL_UNIX_ADDR_DEFAULT="/tmp/mysql.sock"
@@ -68,6 +71,7 @@ romanian russian serbian slovak spanish swedish ukrainian"
AC_SUBST(MYSQL_NO_DASH_VERSION)
AC_SUBST(MYSQL_BASE_VERSION)
AC_SUBST(MYSQL_VERSION_ID)
+AC_SUBST(MYSQL_PREVIOUS_BASE_VERSION)
AC_SUBST(PROTOCOL_VERSION)
AC_DEFINE_UNQUOTED([PROTOCOL_VERSION], [$PROTOCOL_VERSION],
[mysql client protocol version])
@@ -2896,7 +2900,7 @@ AC_CONFIG_FILES(Makefile extra/Makefile mysys/Makefile dnl
cmd-line-utils/libedit/Makefile dnl
win/Makefile dnl
zlib/Makefile dnl
- debian/Makefile dnl
+ debian/Makefile debian/defs.mk dnl
cmd-line-utils/readline/Makefile)
AC_CONFIG_COMMANDS([default], , test -z "$CONFIG_HEADERS" || echo timestamp > stamp-h)
AC_OUTPUT