summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <magnus@msdesk.mysql.com>2005-04-07 14:39:30 +0200
committerunknown <magnus@msdesk.mysql.com>2005-04-07 14:39:30 +0200
commitff700f45c8db2785a9c427d22c757b7f2afde7e8 (patch)
treef2c07eb61b1362c10f8791359266fb1474e26b7a /configure.in
parent0ec06cabbd41ac5a5c13a7cb26074dc938e1b735 (diff)
downloadmariadb-git-ff700f45c8db2785a9c427d22c757b7f2afde7e8.tar.gz
Fix linking problem on bsd53
- See article http://archive.netbsd.se/?ml=freebsd-current&a=2004-07&m=257561 or http://www.geocrawler.com/archives/3/254/2003/3/450/10409564/ configure.in: The libsupc++ library on freebsd with gcc 3.4.2 is dependent on libstdc++, disable it since other solution works fine
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c7e93c9676a..01f669a0d1b 100644
--- a/configure.in
+++ b/configure.in
@@ -351,6 +351,15 @@ then
if echo $CXX | grep gcc > /dev/null 2>&1
then
GCC_VERSION=`gcc -v 2>&1 | grep version | sed -e 's/[[^0-9. ]]//g; s/^ *//g; s/ .*//g'`
+ case $SYSTEM_TYPE in
+ *freebsd*)
+ # The libsupc++ library on freebsd with gcc 3.4.2 is dependent on
+ # libstdc++, disable it since other solution works fine
+ GCC_VERSION="NOSUPCPP_$GCC_VERSION"
+ ;;
+ *)
+ ;;
+ esac
echo "Using gcc version '$GCC_VERSION'"
case "$GCC_VERSION" in
3.4.*|3.5.*)