summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@hundin.mysql.fi>2001-09-18 05:16:39 +0300
committerunknown <monty@hundin.mysql.fi>2001-09-18 05:16:39 +0300
commit01eab0ce84a3f8cef702d9673cc6f6262f4a5a7a (patch)
treebec809e08634f934190434f5e22828676c8b9dfe /configure.in
parentd8ae9669cd11f9c61105a9cbf19f9318a0e783fc (diff)
downloadmariadb-git-01eab0ce84a3f8cef702d9673cc6f6262f4a5a7a.tar.gz
Fix error messages
Configure fixes configure.in: Fix for pstack libmysqld/Makefile.am: Fix to create examples mysql-test/t/drop.test: Fix error messages mysql-test/t/isolation.test: Fix error messages mysql-test/t/union.test: Fix error messages
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 73e38e01fde..a0b6b0bbacb 100644
--- a/configure.in
+++ b/configure.in
@@ -683,15 +683,17 @@ int main()
AC_MSG_RESULT($atom_ops)
AC_ARG_WITH(pstack,
- [ --without-pstack Don't use the pstack backtrace library],
+ [ --without-pstack Do not use the pstack backtrace library],
[USE_PSTACK=$withval],
[USE_PSTACK=yes])
- pstack_libs= pstack_dirs=
- if test "$USE_PSTACK" = yes -a "$IS_LINUX" = "true" -a "$MACHINE_TYPE" = "i386"
+ pstack_libs=
+ pstack_dirs=
+ pstack_makefile=
+ if test "$USE_PSTACK" = yes -a "$IS_LINUX" = "true" -a "$MACHINE_TYPE" = "i686"
then
have_libiberty= have_libbfd=
my_save_LIBS="$LIBS"
-dnl I have no idea if this is a good test - can't find docs for libiberty
+dnl I have no idea if this is a good test - can not find docs for libiberty
AC_CHECK_LIB([iberty], [fdmatch],
[have_libiberty=yes
AC_CHECK_LIB([bfd], [bfd_openr], [have_libbfd=yes], , [-liberty])])
@@ -702,6 +704,7 @@ dnl I have no idea if this is a good test - can't find docs for libiberty
then
pstack_dirs='$(top_srcdir)'/pstack
pstack_libs="$pstack_dirs/libpstack.a -lbfd -liberty"
+ pstack_makefile=pstack/Makefile
AC_SUBST([pstack_dirs])
AC_SUBST([pstack_libs])
AC_DEFINE([USE_PSTACK])
@@ -2219,7 +2222,7 @@ AC_OUTPUT(Makefile extra/Makefile mysys/Makefile isam/Makefile \
man/Makefile readline/Makefile vio/Makefile \
libmysql_r/Makefile libmysqld/Makefile libmysqld/examples/Makefile \
libmysql/Makefile client/Makefile \
- pstack/Makefile sql/Makefile sql/share/Makefile \
+ $pstack_makefile sql/Makefile sql/share/Makefile \
merge/Makefile dbug/Makefile scripts/Makefile \
include/Makefile sql-bench/Makefile tools/Makefile \
tests/Makefile Docs/Makefile support-files/Makefile \