summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@tik.mysql.fi>2001-08-04 00:10:00 +0300
committerunknown <monty@tik.mysql.fi>2001-08-04 00:10:00 +0300
commit9d7a659b21d5afe1073adaa5a9320022683a23cc (patch)
treee66ed14abc4942fc09ac21472d60a38c725d4f39 /configure.in
parent9563e658c986be854453215d22c7e090c4132df6 (diff)
downloadmariadb-git-9d7a659b21d5afe1073adaa5a9320022683a23cc.tar.gz
Fix when using --without-server --with-thread-safe-client
Added prototype for my_thread_end New error message for MATCH Give error when using myisamchk --force --readonly BitKeeper/deleted/.del-fulltext_join.test~e347c8f04405c916: Delete: mysql-test/t/fulltext_join.test Docs/manual.texi: Added node to fulltext configure.in: Fix when using --without-server --with-thread-safe-client include/mysql_com.h: Added prototype for my_thread_end include/mysqld_error.h: New error message for MATCH myisam/myisamchk.c: Give error when using --force --readonly mysql-test/t/fulltext.test: Added test for error conditons with fulltext sql/item_func.cc: Fixed error messages when using MATCH ... AGAINST sql/mysqld.cc: Portability fix sql/share/czech/errmsg.txt: New error message when using MATCH sql/share/danish/errmsg.txt: New error message when using MATCH sql/share/dutch/errmsg.txt: New error message when using MATCH sql/share/english/errmsg.txt: New error message when using MATCH sql/share/estonian/errmsg.txt: New error message when using MATCH sql/share/french/errmsg.txt: New error message when using MATCH sql/share/german/errmsg.txt: New error message when using MATCH sql/share/greek/errmsg.txt: New error message when using MATCH sql/share/hungarian/errmsg.txt: New error message when using MATCH sql/share/italian/errmsg.txt: New error message when using MATCH sql/share/japanese/errmsg.txt: New error message when using MATCH sql/share/korean/errmsg.txt: New error message when using MATCH sql/share/norwegian-ny/errmsg.txt: New error message when using MATCH sql/share/norwegian/errmsg.txt: New error message when using MATCH sql/share/polish/errmsg.txt: New error message when using MATCH sql/share/portuguese/errmsg.txt: New error message when using MATCH sql/share/romanian/errmsg.txt: New error message when using MATCH sql/share/russian/errmsg.txt: New error message when using MATCH sql/share/slovak/errmsg.txt: New error message when using MATCH sql/share/spanish/errmsg.txt: New error message when using MATCH sql/share/swedish/errmsg.OLD: New error message when using MATCH sql/share/swedish/errmsg.txt: New error message when using MATCH
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index cfe6d323021..87a144b4b57 100644
--- a/configure.in
+++ b/configure.in
@@ -4,7 +4,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(sql/mysqld.cc)
AC_CANONICAL_SYSTEM
# The Docs Makefile.am parses this line!
-AM_INIT_AUTOMAKE(mysql, 3.23.40)
+AM_INIT_AUTOMAKE(mysql, 3.23.41)
AM_CONFIG_HEADER(config.h)
PROTOCOL_VERSION=10
@@ -1946,9 +1946,13 @@ AC_SUBST(CLIENT_LIBS)
AC_SUBST(sql_client_dirs)
AC_SUBST(linked_client_targets)
-if test "$with_server" = "yes"
+if test "$with_server" = "yes" -o "$THREAD_SAFE_CLIENT" != "no"
then
AC_DEFINE(THREAD)
+fi
+
+if test "$with_server" = "yes"
+then
# Avoid _PROGRAMS names
THREAD_LPROGRAMS="test_thr_alarm test_thr_lock"
AC_SUBST(THREAD_LPROGRAMS)
@@ -2044,7 +2048,10 @@ EOF
AC_DEFINE(HAVE_GEMINI_DB)
fi
+fi
+if test "$with_server" = "yes" -o "$THREAD_SAFE_CLIENT" != "no"
+then
if test "$with_posix_threads" = "no" -o "$with_mit_threads" = "yes"
then
# MIT user level threads