summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tim@localhost.polyesthetic.msg>2000-08-22 16:08:34 -0400
committerunknown <tim@localhost.polyesthetic.msg>2000-08-22 16:08:34 -0400
commitdb3b3c1799d111a22c5aaead6426b7f064ea8fd9 (patch)
tree0e7c7503846eda7c08f4344ed455ae2de66a3598 /configure.in
parent49b83f3810d20a73d74d0ccaacc22d64a6413569 (diff)
downloadmariadb-git-db3b3c1799d111a22c5aaead6426b7f064ea8fd9.tar.gz
Associate a charset directly with its number in the Index file, and
propogate those changes through the code. This is so that there can be holes in the list of charsets without breaking old tables. configure.in: - changed pattern for getting number from charsets Index file mysys/charset.c: - changed from using a TYPELIB to a CS_ID struct, so both the name and the number of a charset is stored in available_charsets sql/share/charsets/Index: - made the number a real part of the Index file, not just a comment sql/share/charsets/README: - order is no longer significant, but each charset must be paired with its number
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 4 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index f200fefca33..bb3ff9920e6 100644
--- a/configure.in
+++ b/configure.in
@@ -1577,15 +1577,6 @@ do
See the Installation chapter in the Reference Manual.]);
fi
done
-
-default_charset_has_source=0
-for cs in $COMPILED_CHARSETS
-do
- if test $cs = $default_charset
- then
- default_charset_has_source=1
- fi
-done
CHARSET_SRCS=""
CHARSETS_NEED_SOURCE=""
@@ -1600,8 +1591,10 @@ index_file="$srcdir/sql/share/charsets/Index"
for c in $CHARSETS
do
# get the charset number from $index_file
- subpat='^'"${c}"'[[\t ]]*#'
- number=`$AWK 'sub("'"$subpat"'", "") { print }' $index_file`
+changequote(,)dnl
+ subpat='^'"${c}"'[ ][ ]*\([0-9][0-9]*\)[^0-9]*$'
+ number=`sed -e "/$subpat/!d" -e 's//\1/' $index_file`
+changequote([,])dnl
# some sanity checking....
if test X"$number" = X
then