summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <lenz@mysql.com>2004-12-27 18:15:32 +0100
committerunknown <lenz@mysql.com>2004-12-27 18:15:32 +0100
commitdc29b1b90107c035330afb7ff5c394696cedc828 (patch)
tree658ccb121fc1f853030e6f3a0d91c03f5877f759 /configure.in
parent030842edaadf34fe0547bde9d46c6bf285416c88 (diff)
downloadmariadb-git-dc29b1b90107c035330afb7ff5c394696cedc828.tar.gz
- make sure that MYSQL_VERSION_ID created by "configure" does not contain any
non-numerical characters (if $VERSION was e.g. "4.1.8a", $MYSQL_VERSION_ID resulted in "40108a", which broke the build as MYSQL_VERSION_ID must be numerical) configure.in: - make sure that MYSQL_VERSION_ID does not contain any non-numerical characters (if $VERSION was e.g. "4.1.8a", $MYSQL_VERSION_ID resulted in "40108a", which broke the build as MYSQL_VERSION_ID must be numerical)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index bc78c9c8764..f8b40872d3d 100644
--- a/configure.in
+++ b/configure.in
@@ -23,7 +23,7 @@ NDB_VERSION_STATUS=""
# Remember that regexps needs to quote [ and ] since this is run through m4
MYSQL_NO_DASH_VERSION=`echo $VERSION | sed -e "s|[[a-z]]*-.*$||"`
MYSQL_BASE_VERSION=`echo $MYSQL_NO_DASH_VERSION | sed -e "s|\.[[^.]]*$||"`
-MYSQL_VERSION_ID=`echo $MYSQL_NO_DASH_VERSION. | sed -e 's/\./ /g; s/ \([[0-9]]\) / 0\\1 /g; s/ //g'`
+MYSQL_VERSION_ID=`echo $MYSQL_NO_DASH_VERSION. | sed -e 's/[[^0-9.]]//g; s/\./ /g; s/ \([[0-9]]\) / 0\\1 /g; s/ //g'`
# The port should be constant for a LONG time
MYSQL_TCP_PORT_DEFAULT=3306