summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormonty@tik.mysql.fi <>2001-05-28 02:45:19 +0300
committermonty@tik.mysql.fi <>2001-05-28 02:45:19 +0300
commit38c035c09852dd4895177aafe6d73ac8c16919d6 (patch)
tree58dc666b6a55c3f19c8f553d66b95eccd0680274 /configure.in
parent0703dba10da45c58d6abd9ed976ac17c14d26eed (diff)
downloadmariadb-git-38c035c09852dd4895177aafe6d73ac8c16919d6.tar.gz
Fixed portability bug in my_config.sh
Added print of --use-symbolic-links in mysqld
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 9998902bcec..4e73bb901fa 100644
--- a/configure.in
+++ b/configure.in
@@ -285,8 +285,10 @@ export CC CFLAGS LD LDFLAGS
if test "$GXX" = "yes"
then
- # mysqld requires this when compiled with gcc
- CXXFLAGS="$CXXFLAGS -fno-implicit-templates"
+ # mysqld requires -fno-implicit-templates.
+ # Disable exceptions as they seams to create problems with gcc and threads.
+ # mysqld doesn't use run-time-type-checking, so we disable it.
+ CXXFLAGS="$CXXFLAGS -fno-implicit-templates -fno-exceptions -fno-rtti"
fi
# Avoid bug in fcntl on some versions of linux