summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <joreland@mysql.com>2005-01-07 11:47:01 +0100
committerunknown <joreland@mysql.com>2005-01-07 11:47:01 +0100
commitb06480082c8085050eeb3750c56460895666a2b9 (patch)
tree1680d708e5f1d1b39b5725c96900bc979ca09a98 /configure.in
parent51cae387a9a2c67b0f6249864714b8659c951670 (diff)
downloadmariadb-git-b06480082c8085050eeb3750c56460895666a2b9.tar.gz
bug#7690 - ndb startup with shm, use sigaction to escape SA_RESETHAND
configure.in: Check for sigaction used in SHM_Transporter ndb/src/common/transporter/SHM_Transporter.cpp: remove unused variable ndb/src/common/transporter/TransporterRegistry.cpp: 1) remove unused variable 2) Use sigaction instead of signal to install signal handler This as signal uses SA_RESETHAND
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 47447913168..f2184ed7be5 100644
--- a/configure.in
+++ b/configure.in
@@ -1924,7 +1924,7 @@ AC_CHECK_FUNCS(alarm bcmp bfill bmove bzero chsize cuserid fchmod fcntl \
pthread_key_delete pthread_rwlock_rdlock pthread_setprio \
pthread_setprio_np pthread_setschedparam pthread_sigmask readlink \
realpath rename rint rwlock_init setupterm \
- shmget shmat shmdt shmctl \
+ shmget shmat shmdt shmctl sigaction \
sighold sigset sigthreadmask \
snprintf socket stpcpy strcasecmp strerror strnlen strpbrk strstr strtol \
strtoll strtoul strtoull tell tempnam thr_setconcurrency vidattr)
@@ -3097,7 +3097,8 @@ ndb_transporter_opt_objs=""
if test "$ac_cv_func_shmget" = "yes" &&
test "$ac_cv_func_shmat" = "yes" &&
test "$ac_cv_func_shmdt" = "yes" &&
- test "$ac_cv_func_shmctl" = "yes"
+ test "$ac_cv_func_shmctl" = "yes" &&
+ test "$ac_cv_func_sigaction" = "yes"
then
AC_DEFINE([NDB_SHM_TRANSPORTER], [1],
[Including Ndb Cluster DB shared memory transporter])