summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tomas@poseidon.ndb.mysql.com>2004-11-02 19:40:10 +0000
committerunknown <tomas@poseidon.ndb.mysql.com>2004-11-02 19:40:10 +0000
commit5c6cd1f79687c1ef738a3da6ff45166fc90c8f43 (patch)
tree3227893ec8c15e8789e811adf613403c8794cd3d /configure.in
parent5f154fa09087ee978937b8816cda4d4912407c7e (diff)
downloadmariadb-git-5c6cd1f79687c1ef738a3da6ff45166fc90c8f43.tar.gz
add compile flad -DSNPRINTF_RETURN_TRUNC on hp ux 11
remove compiler warning patch for my_vsnprintf not dully implemented patch for platfroms that return -1 on snprintf overflow compile fix for hpux configure.in: add compile flad -DSNPRINTF_RETURN_TRUNC on hp ux 11 ndb/src/common/editline/sysunix.c: remove compiler warning ndb/src/common/util/basestring_vsnprintf.c: patch for my_vsnprintf not dully implemented patch for platfroms that return -1 on snprintf overflow ndb/src/kernel/vm/Emulator.hpp: compile fix for hpux ndb/src/mgmsrv/Services.cpp: compile fix for hp ux ndb/src/ndbapi/NdbDictionaryImpl.cpp: remove compiler warning
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d63859720a3..71adaa747f5 100644
--- a/configure.in
+++ b/configure.in
@@ -1039,8 +1039,8 @@ case $SYSTEM_TYPE in
;;
*hpux11.*)
echo "Enabling workarounds for hpux 11"
- CFLAGS="$CFLAGS -DHPUX11 -DHAVE_BROKEN_PREAD -DDONT_USE_FINITE -DHAVE_BROKEN_GETPASS -DNO_FCNTL_NONBLOCK -DDO_NOT_REMOVE_THREAD_WRAPPERS -DHAVE_BROKEN_PTHREAD_COND_TIMEDWAIT"
- CXXFLAGS="$CXXFLAGS -DHPUX11 -DHAVE_BROKEN_PREAD -DDONT_USE_FINITE -D_INCLUDE_LONGLONG -DNO_FCNTL_NONBLOCK -DDO_NOT_REMOVE_THREAD_WRAPPERS -DHAVE_BROKEN_PTHREAD_COND_TIMEDWAIT"
+ CFLAGS="$CFLAGS -DHPUX11 -DSNPRINTF_RETURN_TRUNC -DHAVE_BROKEN_PREAD -DDONT_USE_FINITE -DHAVE_BROKEN_GETPASS -DNO_FCNTL_NONBLOCK -DDO_NOT_REMOVE_THREAD_WRAPPERS -DHAVE_BROKEN_PTHREAD_COND_TIMEDWAIT"
+ CXXFLAGS="$CXXFLAGS -DHPUX11 -DSNPRINTF_RETURN_TRUNC -DHAVE_BROKEN_PREAD -DDONT_USE_FINITE -D_INCLUDE_LONGLONG -DNO_FCNTL_NONBLOCK -DDO_NOT_REMOVE_THREAD_WRAPPERS -DHAVE_BROKEN_PTHREAD_COND_TIMEDWAIT"
if test "$with_named_thread" = "no"
then
echo "Using --with-named-thread=-lpthread"