summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@mashka.mysql.fi>2003-01-05 20:18:49 +0200
committerunknown <monty@mashka.mysql.fi>2003-01-05 20:18:49 +0200
commite3c7f4d85ec4caf59fc408cf5643e5dc64e9a3d4 (patch)
treece42417ba1ab6dac8c367a9ae180ea377956e95a /configure.in
parent79fba6da8f099566bbf711b592aab60909b1f66d (diff)
downloadmariadb-git-e3c7f4d85ec4caf59fc408cf5643e5dc64e9a3d4.tar.gz
A lot of portability fixes.
Added rename table for BDB. This fixes a bug in ALTER TABLE with BDB tables. BUILD/SETUP.sh: Enabled uninitalized warnings for debug builds. Build-tools/Do-compile: Added options --no-mysqltest and --no-benchmarks Log time before each stage Removed warnings on some OS (at least hpux11) acinclude.m4: Fixed call to wrong function configure.in: Don't use -O3 as compiler option with aCC innobase/include/univ.i: Removed compiler warning (on Hpux11) innobase/os/os0file.c: Removed compiler warning (on Hpux11) innobase/trx/trx0sys.c: Removed compiler warning (on Hpux11) innobase/trx/trx0trx.c: Removed compiler warning (on Hpux11) innobase/ut/ut0ut.c: Removed compiler warning (with gcc) myisam/mi_check.c: Added missing 'static' myisam/mi_test1.c: Added missing 'static' mysys/my_getopt.c: Added missing 'static' sql/ha_berkeley.cc: Added rename table. This fixes a bug in ALTER TABLE with BDB tables. Fixed compilation problem on OSF1 sql/ha_berkeley.h: Added rename table. This fixes a bug in ALTER TABLE with BDB tables. sql/mini_client.cc: Added reinterpret cast to avoid some warnings. sql/sql_parse.cc: Added reinterpret cast to avoid some warnings. Removed usage of strnlen() as this gave portability problems. sql/sql_union.cc: Added reinterpret cast to avoid some warnings. sql/table.cc: Added reinterpret cast to avoid some warnings. tools/mysqlmanager.c: Added missing 'static'
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9e3a8ffc516..0375cc61235 100644
--- a/configure.in
+++ b/configure.in
@@ -879,6 +879,7 @@ int main()
#
MAX_C_OPTIMIZE="-O3"
+MAX_CXX_OPTIMIZE="-O3"
case $SYSTEM_TYPE in
*solaris2.7*)
@@ -946,6 +947,8 @@ case $SYSTEM_TYPE in
then
CFLAGS="$CFLAGS +DD64 -DHAVE_BROKEN_INLINE"
CXXFLAGS="$CXXFLAGS +DD64 +O2"
+ MAX_C_OPTIMIZE=""
+ MAX_CXX_OPTIMIZE=""
fi
;;
*rhapsody*)
@@ -1404,7 +1407,7 @@ if test "$ac_cv_prog_cxx_g" = "yes"
then
DEBUG_CXXFLAGS="-g"
DEBUG_OPTIMIZE_CXX="-O"
- OPTIMIZE_CXXFLAGS="-O3"
+ OPTIMIZE_CXXFLAGS="$MAX_CXX_OPTIMIZE"
else
DEBUG_CXXFLAGS="-g"
DEBUG_OPTIMIZE_CXX=""