summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tim@cane.mysql.fi>2001-01-05 11:35:08 +0200
committerunknown <tim@cane.mysql.fi>2001-01-05 11:35:08 +0200
commit53bac88ba9b01fa3bae23e3df2f02c721ca0d507 (patch)
tree2c9e7a2f78868e800e103cf3101604bfd1f27524 /configure.in
parent828a5ff538dfb58ce85acc6e4f14c3360c9dae3c (diff)
downloadmariadb-git-53bac88ba9b01fa3bae23e3df2f02c721ca0d507.tar.gz
configure.in Change PERL test to use perl instead of perl5, if possible.
configure.in: Change PERL test to use perl instead of perl5, if possible.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 4a0acd2ab0b..bd42c516baf 100644
--- a/configure.in
+++ b/configure.in
@@ -296,13 +296,21 @@ AC_PATH_PROG(CMP, cmp, cmp)
AC_PATH_PROG(CHMOD, chmod, chmod)
AC_PATH_PROG(HOSTNAME, hostname, hostname)
dnl We use a path for perl so the script startup works
-AC_PATH_PROG(PERL5, perl5, no)
+dnl We make sure to use perl, not perl5, in hopes that the RPMs will
+dnl not depend on the perl5 binary being installed (probably a bug in RPM)
AC_PATH_PROG(PERL, perl, no)
-if test "$PERL5" != no
+if test "$PERL" != "no" && $PERL -e 'require 5' > /dev/null 2>&1
then
- PERL=$PERL5
- ac_cv_path_PERL=$ac_cv_path_PERL5
+ PERL5=$PERL
+else
+ AC_PATH_PROG(PERL5, perl5, no)
+ if test "$PERL5" != no
+ then
+ PERL=$PERL5
+ ac_cv_path_PERL=$ac_cv_path_PERL5
+ fi
fi
+
AC_SUBST(HOSTNAME)
AC_SUBST(PERL)
AC_SUBST(PERL5)