summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2005-04-27 11:25:08 +0200
committerunknown <msvensson@neptunus.(none)>2005-04-27 11:25:08 +0200
commit072fa90d9e7f5ac4df1fb42054b906b872497113 (patch)
treeffe13a13497b747762b2e275e63a444e442611a6 /configure.in
parent9e7028c8e0708877fa802a1b589f695d78ccd1ea (diff)
downloadmariadb-git-072fa90d9e7f5ac4df1fb42054b906b872497113.tar.gz
BUG#9714 libsupc++ problem
- Remove linking of libsupc++ - Move all local static variables to filescope configure.in: Remove linking with libsupc++ sql/examples/ha_archive.cc: Move local static variables to file scope sql/examples/ha_example.cc: Move local static variables to file scope sql/examples/ha_tina.cc: Move local static variables to file scope sql/ha_berkeley.cc: Move local static variables to file scope sql/ha_blackhole.cc: Move local static variables to file scope sql/ha_federated.cc: Move local static variables to file scope sql/ha_heap.cc: Move local static variables to file scope sql/ha_innodb.cc: Move local static variables to file scope sql/ha_myisam.cc: Move local static variables to file scope sql/ha_myisammrg.cc: Move local static variables to file scope sql/ha_ndbcluster.cc: Move local static variables to file scope sql/item.cc: Move local static instance variables to file scope sql/item_sum.cc: Move local static variables to file scope
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in38
1 files changed, 9 insertions, 29 deletions
diff --git a/configure.in b/configure.in
index ff4527ee09f..a5b9edae877 100644
--- a/configure.in
+++ b/configure.in
@@ -336,7 +336,7 @@ AC_SUBST(LD)
AC_SUBST(INSTALL_SCRIPT)
export CC CXX CFLAGS LD LDFLAGS AR
-
+echo "GXX: $GXX"
if test "$GXX" = "yes"
then
# mysqld requires -fno-implicit-templates.
@@ -344,36 +344,16 @@ then
# mysqld doesn't use run-time-type-checking, so we disable it.
CXXFLAGS="$CXXFLAGS -fno-implicit-templates -fno-exceptions -fno-rtti"
- # If you are using 'gcc' 3.0 (not g++) to compile C++ programs on Linux,
- # we will gets some problems when linking static programs.
- # The following code is used to fix this problem.
-
+ #CXX_VERNO=`echo $CXX_VERSION | sed -e 's/[[^0-9. ]]//g; s/^ *//g; s/ .*//g'`
+ echo "CXX: $CXX"
if echo $CXX | grep gcc > /dev/null 2>&1
then
- GCC_VERSION=`gcc -v 2>&1 | grep version | sed -e 's/[[^0-9. ]]//g; s/^ *//g; s/ .*//g'`
- case $SYSTEM_TYPE in
- *freebsd*)
- # The libsupc++ library on freebsd with gcc 3.4.2 is dependent on
- # libstdc++, disable it since other solution works fine
- GCC_VERSION="NOSUPCPP_$GCC_VERSION"
- ;;
- *)
- ;;
- esac
- echo "Using gcc version '$GCC_VERSION'"
- case "$GCC_VERSION" in
- 3.4.*|3.5.*)
- # Statically link the language support function's found in libsupc++.a
- LIBS="$LIBS -lsupc++"
- echo "Using -libsupc++ for static linking with gcc"
- ;;
- *)
- # Using -lsupc++ doesn't work in gcc 3.3 on SuSE 9.2
- # (causes link failures when linking things staticly)
- CXXFLAGS="$CXXFLAGS -DUSE_MYSYS_NEW -DDEFINE_CXA_PURE_VIRTUAL"
- echo "Using MYSYS_NEW for static linking with gcc"
- ;;
- esac
+ echo "Setting CXXFLAGS"
+ # If you are using 'gcc' 3.0 (not g++) to compile C++ programs on Linux,
+ # we will gets some problems when linking static programs.
+ # The following code is used to fix this problem.
+ CXXFLAGS="$CXXFLAGS -DUSE_MYSYS_NEW -DDEFINE_CXA_PURE_VIRTUAL"
+ echo "Using MYSYS_NEW for static linking with gcc"
fi
fi