summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2007-01-01 08:49:17 +0100
committerunknown <kent@mysql.com/kent-amd64.(none)>2007-01-01 08:49:17 +0100
commit6c2883fc2eeb8d108e981f8ecb020ce2720f14c8 (patch)
treef5cd863c345903620e68d3d6c230954e4cf3b7ec /configure.in
parent4a090b1842b0ff0c136d9d180933ee2a55597135 (diff)
downloadmariadb-git-6c2883fc2eeb8d108e981f8ecb020ce2720f14c8.tar.gz
configure.in:
Build "mysqld_error.h" even if configured --withouth-server (bug#21265) configure.in: Build "mysqld_error.h" even if configured --withouth-server (bug#21265)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 3cf7327d185..26ccd3f4155 100644
--- a/configure.in
+++ b/configure.in
@@ -2494,12 +2494,14 @@ thread_dirs=
dnl This probably should be cleaned up more - for now the threaded
dnl client is just using plain-old libs.
-sql_client_dirs="strings regex mysys libmysql client"
+sql_client_dirs=
linked_client_targets="linked_libmysql_sources"
-if test "$THREAD_SAFE_CLIENT" != "no"
+if test "$THREAD_SAFE_CLIENT" = "no"
then
- sql_client_dirs="libmysql_r $sql_client_dirs"
+ sql_client_dirs="strings regex mysys extra libmysql client"
+else
+ sql_client_dirs="strings regex mysys extra libmysql libmysql_r client"
linked_client_targets="$linked_client_targets linked_libmysql_r_sources"
AC_CONFIG_FILES(libmysql_r/Makefile)
AC_DEFINE([THREAD_SAFE_CLIENT], [1], [Should be client be thread safe])
@@ -2532,13 +2534,13 @@ if test "$with_server" != "no" -o "$THREAD_SAFE_CLIENT" != "no"
then
AC_DEFINE([THREAD], [1],
[Define if you want to have threaded code. This may be undef on client code])
+ # Avoid _PROGRAMS names
+ THREAD_LOBJECTS="thr_alarm.o thr_lock.o thr_mutex.o thr_rwlock.o my_pthread.o my_thr_init.o mf_keycache.o"
+ AC_SUBST(THREAD_LOBJECTS)
fi
if test "$with_server" != "no"
then
- # Avoid _PROGRAMS names
- THREAD_LOBJECTS="thr_alarm.o thr_lock.o thr_mutex.o thr_rwlock.o my_pthread.o my_thr_init.o mf_keycache.o"
- AC_SUBST(THREAD_LOBJECTS)
server_scripts="mysqld_safe mysql_install_db"
sql_server_dirs="strings mysys dbug extra regex"