summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@hundin.mysql.fi>2001-05-31 12:19:16 +0300
committerunknown <monty@hundin.mysql.fi>2001-05-31 12:19:16 +0300
commitb369c09dc252e897d367cf0f864141ebd26aba26 (patch)
treef3386d22e6d91d2fda383ebdb01fdb4614ff56ad /configure.in
parent1158d8a263c750fd96c43a9c6bcc37bba8e9fb5c (diff)
parentb6cae0f64707aca9ec2bbc437f87a84e53fbfec7 (diff)
downloadmariadb-git-b369c09dc252e897d367cf0f864141ebd26aba26.tar.gz
Merge work:/home/bk/mysql into hundin.mysql.fi:/my/bk/mysql
BitKeeper/etc/logging_ok: auto-union configure.in: Auto merged Docs/manual.texi: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 38df0e950c4..37bc22ff63e 100644
--- a/configure.in
+++ b/configure.in
@@ -755,6 +755,11 @@ case $SYSTEM_TYPE in
echo "Enabling snprintf workaround for hpux 10.20"
CFLAGS="$CFLAGS -DHAVE_BROKEN_SNPRINTF -DSIGNALS_DONT_BREAK_READ"
CXXFLAGS="$CXXFLAGS -DHAVE_BROKEN_SNPRINTF -D_INCLUDE_LONGLONG -DSIGNALS_DONT_BREAK_READ"
+ if test "$with_named_thread" = "no"
+ then
+ echo "Using --with-named-thread=-lpthread"
+ with_named_thread="-lcma"
+ fi
;;
*hpux11.*)
echo "Enabling pread/pwrite workaround for hpux 11"
@@ -1051,7 +1056,7 @@ fi
AC_MSG_CHECKING("named thread libs:")
if test "$with_named_thread" != "no"
then
- LIBS="$LIBS $with_named_thread"
+ LIBS="$with_named_thread $LIBS $with_named_thread"
with_posix_threads="yes"
with_mit_threads="no"
AC_MSG_RESULT("$with_named_thread")