summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tim@threads.polyesthetic.msg>2001-03-05 14:30:39 -0500
committerunknown <tim@threads.polyesthetic.msg>2001-03-05 14:30:39 -0500
commitc5a52087a4a006cd6cd04972b1310d13a9bf11ce (patch)
treef875e030e6d873392e06bcc1fbaa16a2e16cff35 /configure.in
parentea7f14cf360196ec06d1de8b696cac9317c7dc12 (diff)
downloadmariadb-git-c5a52087a4a006cd6cd04972b1310d13a9bf11ce.tar.gz
Berkeley DB now uses our own Makefile.in which translates automake
targets (like 'distdir') properly. configure.in: BDB subdir is now 'bdb', not 'bdb/build_unix'. Remove code that modifies the bdb/build_unix/Makefile, because it's no longer needed.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 2 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 56027305bdf..1bac02c3591 100644
--- a/configure.in
+++ b/configure.in
@@ -1869,7 +1869,7 @@ then
if test X"$have_berkeley_db" != Xno; then
if test X"$have_berkeley_db" != Xyes; then
# we must build berkeley db from source
- sql_server_dirs="$have_berkeley_db/build_unix $sql_server_dirs"
+ sql_server_dirs="$have_berkeley_db $sql_server_dirs"
echo "CONFIGURING FOR BERKELEY DB"
bdb_conf_flags=
@@ -1880,19 +1880,6 @@ then
(cd $bdb && cd build_unix && sh ../dist/configure $bdb_conf_flags) \
|| AC_MSG_ERROR([could not configure Berkeley DB])
- echo "Modifying Berkeley DB install target"
- sed -e '/^install:/ c\
-install: all # modified by MySQL configure\
-dnl This is needed because in some versions of BDB the install target
-dnl is continued on a second line.
-mysql-noinstall-hack:' \
- "$bdb/build_unix/Makefile" > ac_BDB_Makefile
-
- rm "$bdb/build_unix/Makefile" \
- && cp ac_BDB_Makefile "$bdb/build_unix/Makefile" \
- && rm ac_BDB_Makefile \
- || AC_MSG_ERROR([could not modify Berkeley DB Makefile])
-
echo "END OF BERKELEY DB CONFIGURATION"
fi
@@ -1944,6 +1931,7 @@ AC_SUBST(GXX)
# Output results
AC_OUTPUT(Makefile extra/Makefile mysys/Makefile isam/Makefile \
strings/Makefile regex/Makefile heap/Makefile \
+ bdb/Makefile \
myisam/Makefile myisammrg/Makefile \
man/Makefile \
readline/Makefile libmysql_r/Makefile libmysql/Makefile client/Makefile \