summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2006-05-16 22:47:22 +0200
committerunknown <kent@mysql.com>2006-05-16 22:47:22 +0200
commit61bd3fa055e6d3e39ac20ed3c7568cccf955cf6e (patch)
treeabfc73003192b7a0e3d43b124d5ab76518872870 /configure.in
parentaba2ccbcc88a8e82c475a711cfda011a323cb775 (diff)
downloadmariadb-git-61bd3fa055e6d3e39ac20ed3c7568cccf955cf6e.tar.gz
mysql.spec.sh:
Removed Berkeley DB configure.in: Adjusted Netware support basic.t.c: Change for Netware Makefile.am: Use thread safe libmysqlclient_r if it was built valgrind.supp: Hide report about strlen/_dl_init_paths ha_tina.cc: Temporarely disable CSV engine on Netware, as the engine depends on mmap() net_serv.cc: Include <sys/select.h> for Netware sql/net_serv.cc: Include <sys/select.h> for Netware storage/csv/ha_tina.cc: Temporarely disable CSV engine on Netware, as the engine depends on mmap() mysql-test/valgrind.supp: Hide report about strlen/_dl_init_paths tests/Makefile.am: Use thread safe libmysqlclient_r if it was built unittest/mytap/t/basic.t.c: Change for Netware configure.in: Adjusted Netware support support-files/mysql.spec.sh: Removed Berkeley DB
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 4 insertions, 23 deletions
diff --git a/configure.in b/configure.in
index e159a5803f1..71f6f9d89ab 100644
--- a/configure.in
+++ b/configure.in
@@ -1088,7 +1088,7 @@ dnl Is this the right match for DEC OSF on alpha?
# Edit Makefile.in files.
#
echo -n "configuring Makefile.in files for NetWare... "
- for file in sql/Makefile.in libmysql/Makefile.in libmysql_r/Makefile.in sql/share/Makefile.in strings/Makefile.in client/Makefile.in
+ for file in sql/Makefile.in extra/Makefile.in client/Makefile.in
do
# echo "#### $file ####"
filedir="`dirname $file`"
@@ -1109,32 +1109,13 @@ dnl Is this the right match for DEC OSF on alpha?
# Add library dependencies to mysqld_DEPENDENCIES
lib_DEPENDENCIES="\$(pstack_libs) \$(openssl_libs) \$(yassl_libs)"
cat > $filesed << EOF
-s,\(^.*\$(MAKE) gen_lex_hash\)\$(EXEEXT),#\1,
s,\(\./gen_lex_hash\)\$(EXEEXT),\1.linux,
-s%\(mysqld_DEPENDENCIES = \) %\1$lib_DEPENDENCIES %
+s%\(mysqld_DEPENDENCIES = \)%\1$lib_DEPENDENCIES %
EOF
;;
- sql/share/Makefile.in)
+ extra/Makefile.in)
cat > $filesed << EOF
-s,\(extra/comp_err\),\1.linux,
-EOF
- ;;
- libmysql/Makefile.in)
- cat > $filesed << EOF
-s,\(\./conf_to_src\)\( \$(top_srcdir)\),\1.linux\2,
-s,\(: conf_to_src\),\1.linux,
-EOF
- ;;
- libmysql_r/Makefile.in)
- cat > $filesed << EOF
-s,\(\./conf_to_src\)\( \$(top_srcdir)\),\1.linux\2,
-s,\(: conf_to_src\),\1.linux,
-EOF
- ;;
- strings/Makefile.in)
- cat > $filesed << EOF
-s,\(\./conf_to_src\)\( \$(top_srcdir)\),\1.linux\2,
-s,\(: conf_to_src\),\1.linux,
+s,\(extra/comp_err\)\$(EXEEXT),\1.linux,
EOF
;;
client/Makefile.in)