summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoerg Bruehe <joerg.bruehe@oracle.com>2011-07-08 16:25:32 +0200
committerJoerg Bruehe <joerg.bruehe@oracle.com>2011-07-08 16:25:32 +0200
commit70fbfa0ce2f3310f2a80e424e0d96ff8234ed91b (patch)
tree693c6355dc581d3a0c0ed099a276cb0edc652f34 /configure.in
parentc6669b46d6b3bc885e6dc30916314476def75cf9 (diff)
downloadmariadb-git-70fbfa0ce2f3310f2a80e424e0d96ff8234ed91b.tar.gz
Fix Bug #47337:
innochecksum not built for --with-plugin-innodb_plugin --without-plugin-innobase In 5.1, we can have the traditional "innobase" code (built-in) or the new version "innodb" (plugin). The help tool "innochecksum" is useful for both, but its generation was coupled to "innobase" only. Fix this by treating both "innobase" and "innodb" equivalent in the configure phase, this affects both "innochecksum" and the InnoDB documentation. This patch was proposed by Mark Callaghan.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0948fe1349d..fffbde0fd00 100644
--- a/configure.in
+++ b/configure.in
@@ -2711,7 +2711,7 @@ then
MAN_DROP="$MAN_DROP embedded"
grep -v 'embedded' $MANLISTFIL > $TMPLISTFIL ; mv -f $TMPLISTFIL $MANLISTFIL
fi
- if test X"$with_plugin_innobase" != Xyes
+ if test X"$with_plugin_innobase" != Xyes -a X"$with_plugin_innodb_plugin" != Xyes
then
MAN_DROP="$MAN_DROP innodb"
grep -v 'inno' $MANLISTFIL > $TMPLISTFIL ; mv -f $TMPLISTFIL $MANLISTFIL
@@ -2790,7 +2790,7 @@ then
fi
# "innochecksum" is not in the "innobase/" subdirectory, but should be switched
-AM_CONDITIONAL([BUILD_INNODB_TOOLS], [test X"$with_plugin_innobase" = Xyes])
+AM_CONDITIONAL([BUILD_INNODB_TOOLS], [test X"$with_plugin_innobase" = Xyes -o X"$with_plugin_innodb_plugin" = Xyes ])
# IMPORTANT - do not modify LIBS past this line - this hack is the only way
# I know to add the static NSS magic if we have static NSS libraries with