summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@tik.mysql.fi>2001-05-28 02:45:19 +0300
committerunknown <monty@tik.mysql.fi>2001-05-28 02:45:19 +0300
commitbd130011e1fb1ef78c78e166559f8ee6fcb9e5da (patch)
tree58dc666b6a55c3f19c8f553d66b95eccd0680274 /configure.in
parentcf5233e47c8219f8e2f17b85f02110efc396fd90 (diff)
downloadmariadb-git-bd130011e1fb1ef78c78e166559f8ee6fcb9e5da.tar.gz
Fixed portability bug in my_config.sh
Added print of --use-symbolic-links in mysqld Docs/manual.texi: Added new links configure.in: Fixes for gcc scripts/mysql_config.sh: Fixed portability bug. sql/mysqld.cc: Added print of --use-symbolic-links
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 9998902bcec..4e73bb901fa 100644
--- a/configure.in
+++ b/configure.in
@@ -285,8 +285,10 @@ export CC CFLAGS LD LDFLAGS
if test "$GXX" = "yes"
then
- # mysqld requires this when compiled with gcc
- CXXFLAGS="$CXXFLAGS -fno-implicit-templates"
+ # mysqld requires -fno-implicit-templates.
+ # Disable exceptions as they seams to create problems with gcc and threads.
+ # mysqld doesn't use run-time-type-checking, so we disable it.
+ CXXFLAGS="$CXXFLAGS -fno-implicit-templates -fno-exceptions -fno-rtti"
fi
# Avoid bug in fcntl on some versions of linux