summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormonty@mysql.com <>2006-02-25 17:46:30 +0200
committermonty@mysql.com <>2006-02-25 17:46:30 +0200
commit54274976e7b4a9a28e94a6f0b4f8d064140248db (patch)
tree563e06651e9166da59ba432a876beee5175b6229 /configure.in
parenta7df038d168889ae3ba8e81f6303c779c0707fae (diff)
downloadmariadb-git-54274976e7b4a9a28e94a6f0b4f8d064140248db.tar.gz
Fixed compiler warnings from gcc 4.0.2:
- Added empty constructors and virtual destructors to many classes and structs - Removed some usage of the offsetof() macro to instead use C++ class pointers
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2ba832d4e2b..7a571da7d77 100644
--- a/configure.in
+++ b/configure.in
@@ -356,6 +356,9 @@ then
# mysqld requires -fno-implicit-templates.
# Disable exceptions as they seams to create problems with gcc and threads.
# mysqld doesn't use run-time-type-checking, so we disable it.
+ # We should use -Wno-invalid-offsetof flag to disable some warnings from gcc
+ # regarding offset() usage in C++ which are done in a safe manner in the
+ # server
CXXFLAGS="$CXXFLAGS -fno-implicit-templates -fno-exceptions -fno-rtti"
AC_DEFINE([HAVE_EXPLICIT_TEMPLATE_INSTANTIATION],
[1], [Defined by configure. Use explicit template instantiation.])