summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorbell@sanja.is.com.ua <>2006-04-24 13:32:07 +0300
committerbell@sanja.is.com.ua <>2006-04-24 13:32:07 +0300
commitb2c810e8475c43c85472b2a3e3074cb36c69d20e (patch)
treeb4b53f9873d5ee576a5ea0a905753163cd7fc022 /configure.in
parent92a8da8b188e1cf363d89889471a6998b14d6aea (diff)
parent5c7955bd54ecd4a686614d38470e79e9fef4872a (diff)
downloadmariadb-git-b2c810e8475c43c85472b2a3e3074cb36c69d20e.tar.gz
Merge sanja.is.com.ua:/home/bell/mysql/bk/mysql-5.0
into sanja.is.com.ua:/home/bell/mysql/bk/work-merge-5.1
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 44e9d286e1f..2fde26d5930 100644
--- a/configure.in
+++ b/configure.in
@@ -775,6 +775,9 @@ AC_SUBST(WRAPLIBS)
if test "$TARGET_LINUX" = "true"; then
AC_MSG_CHECKING([for atomic operations])
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+
atom_ops=
AC_TRY_RUN([
#include <asm/atomic.h>
@@ -810,6 +813,8 @@ int main()
if test -z "$atom_ops"; then atom_ops="no"; fi
AC_MSG_RESULT($atom_ops)
+ AC_LANG_RESTORE
+
AC_ARG_WITH(pstack,
[ --with-pstack Use the pstack backtrace library],
[ USE_PSTACK=$withval ],