summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <df@kahlann.erinye.com>2007-01-25 09:18:10 +0100
committerunknown <df@kahlann.erinye.com>2007-01-25 09:18:10 +0100
commit244046164164b110ccfb915790fb7663e0e5d880 (patch)
tree74e1edcc598bfe622247cb90045067c268a3a77f /configure.in
parente57ef96a08b7339a9e6a546fd8a603d98a6aa072 (diff)
parent6cfffb500532cf8769013fc57e7140b861811632 (diff)
downloadmariadb-git-244046164164b110ccfb915790fb7663e0e5d880.tar.gz
merge fix
sql/ha_ndbcluster.cc: Auto merged sql/mysqld.cc: Auto merged sql/sql_class.cc: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 15 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 17a9714c16c..1e36502fa19 100644
--- a/configure.in
+++ b/configure.in
@@ -2354,6 +2354,7 @@ readline_basedir=""
readline_dir=""
readline_h_ln_cmd=""
readline_link=""
+want_to_use_readline="no"
if expr "$SYSTEM_TYPE" : ".*netware.*" > /dev/null
then
@@ -2379,6 +2380,7 @@ then
readline_link="\$(top_builddir)/cmd-line-utils/readline/libreadline.a"
readline_h_ln_cmd="\$(LN) -s \$(top_srcdir)/cmd-line-utils/readline readline"
compile_readline=yes
+ want_to_use_readline="yes"
AC_DEFINE_UNQUOTED(USE_NEW_READLINE_INTERFACE, 1)
else
# Use system readline library
@@ -2388,10 +2390,12 @@ else
MYSQL_CHECK_NEW_RL_INTERFACE
MYSQL_CHECK_READLINE_DECLARES_HIST_ENTRY
AC_LANG_RESTORE
- if [test "$mysql_cv_new_rl_interface" = "yes"]
+ if [test "$mysql_cv_new_rl_interface" = "yes"] && [test -d "./cmd-line-utils/readline"]
then
- # Use the new readline interface
+ # Use the new readline interface, but only if the package includes a bundled libreadline
+ # this way we avoid linking commercial source with GPL readline
readline_link="-lreadline"
+ want_to_use_readline="yes"
elif [test "$mysql_cv_libedit_interface" = "yes"]
then
# Use libedit
@@ -2402,6 +2406,15 @@ else
versions of libedit or readline])
fi
fi
+
+# if there is no readline, but we want to build with readline, we fail
+if [test "$want_to_use_readline" = "yes"] && [test ! -d "./cmd-line-utils/readline"]
+then
+ AC_MSG_ERROR([This commercially licensed MySQL source package can't
+ be built with libreadline. Please use --with-libedit to use
+ the bundled version of libedit instead.])
+fi
+
#
# if either readline or libedit is enabled - generate Makefile's for both
# (to make sure both are included in 'make dist')