summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <brian@zim.(none)>2006-11-10 17:21:59 -0800
committerunknown <brian@zim.(none)>2006-11-10 17:21:59 -0800
commit81d3eb54407d65c06f80c2dfe38e5be3ceb1d40a (patch)
tree37454e0e0b2e40acf79f5fb9ee63b0cc5548d3c0 /configure.in
parent53a95766b41d93cef9f00c089c8879edbc164308 (diff)
downloadmariadb-git-81d3eb54407d65c06f80c2dfe38e5be3ceb1d40a.tar.gz
This patch fixes the example engine, the example parser, and the example daemon to compile. AKA You can now test that the interface is actually working :)
configure.in: Removed unneeded call to old plugin syntax. include/mysql/plugin.h: Updates for daemon type (and fixed warning on declare end). plugin/fulltext/Makefile.am: Updated names so that we can install and test it. plugin/fulltext/plugin_example.c: Fixed wrong call. sql/mysqld.cc: Removed old have_example (we don't need it any longer). sql/set_var.cc: Removed old have_example sql/sql_plugin.cc: Added support for DAEMON type (just an internal raw plugin) storage/example/plug.in: Removed example static build so that we can test dynamic engines plugin/daemon_example/AUTHORS: New BitKeeper file ``plugin/daemon_example/AUTHORS'' plugin/daemon_example/ChangeLog: New BitKeeper file ``plugin/daemon_example/ChangeLog'' plugin/daemon_example/Makefile.am: New BitKeeper file ``plugin/daemon_example/Makefile.am'' plugin/daemon_example/NEWS: New BitKeeper file ``plugin/daemon_example/NEWS'' plugin/daemon_example/README: New BitKeeper file ``plugin/daemon_example/README'' plugin/daemon_example/configure.in: New BitKeeper file ``plugin/daemon_example/configure.in'' plugin/daemon_example/daemon_example.c: New BitKeeper file ``plugin/daemon_example/daemon_example.c'' plugin/daemon_example/plug.in: New BitKeeper file ``plugin/daemon_example/plug.in'' plugin/fulltext/plug.in: Added plug.in file so that we compile fulltext example!
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 0 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 61eb8a9d259..378871d3038 100644
--- a/configure.in
+++ b/configure.in
@@ -2141,10 +2141,6 @@ MYSQL_CHECK_SSL
# Has to be done late, as the plugin may need to check for existence of
# functions tested above
#--------------------------------------------------------------------
-MYSQL_PLUGIN(ftexample, [Simple Parser],
- [Simple full-text parser plugin])
-MYSQL_PLUGIN_DIRECTORY(ftexample, [plugin/fulltext])
-MYSQL_PLUGIN_DYNAMIC(ftexample, [mypluglib.la])
MYSQL_STORAGE_ENGINE(partition, partition, [Partition Support],
[MySQL Partitioning Support], [max,max-no-ndb])