summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjoerg@debian.(none) <>2007-04-20 12:25:50 +0200
committerjoerg@debian.(none) <>2007-04-20 12:25:50 +0200
commit88d88e7f7a9f28fa0d5ffcd7c52605bc2dee7973 (patch)
treedf0671dc04129b4cbfeba24df027193b8cb48ad0 /configure.in
parent5d4a912e544382e0314f5dedd2a1da6f6c49b948 (diff)
parent5de73f45f93988351e620781ae6e631c3760a7fc (diff)
downloadmariadb-git-88d88e7f7a9f28fa0d5ffcd7c52605bc2dee7973.tar.gz
Merge debian.(none):/M50/bug27739-5.0
into debian.(none):/M50/push-5.0
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 75a006ac07a..d5ff3afa57b 100644
--- a/configure.in
+++ b/configure.in
@@ -459,6 +459,22 @@ AC_SUBST(MAKEINDEX)
# icheck, used for ABI check
AC_PATH_PROG(ICHECK, icheck, no)
+# "icheck" is also the name of a file system check program on Tru64.
+# Verify the program found is really the interface checker.
+if test "x$ICHECK" != "xno"
+then
+ AC_MSG_CHECKING(if $ICHECK works as expected)
+ echo "int foo;" > conftest.h
+ $ICHECK --canonify -o conftest.ic conftest.h 2>/dev/null
+ if test -f "conftest.ic"
+ then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ ICHECK=no
+ fi
+ rm -f conftest.ic conftest.h
+fi
AC_SUBST(ICHECK)
# Lock for PS