summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjoerg@trift2. <>2007-10-15 19:59:14 +0200
committerjoerg@trift2. <>2007-10-15 19:59:14 +0200
commit9dfa790ffcb3928c0cbed8fdbe0a8bad87ce1581 (patch)
tree53b4b3deec628985931fe5e0ee34931b7e727187 /configure.in
parentbcbb31d44d49ce9e3b240ff510d9c62b4d2e4e9c (diff)
downloadmariadb-git-9dfa790ffcb3928c0cbed8fdbe0a8bad87ce1581.tar.gz
Allow for different directories containing the "libc",
as it may well happen with 32- vs 64-bit Linux systems. This patch was proposed immediately with the report of Bug #29658 wrong test for static nss checking on linux, doesn't cover all platforms
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d27c77d49b1..92900d0630d 100644
--- a/configure.in
+++ b/configure.in
@@ -631,7 +631,7 @@ AC_SUBST(NOINST_LDFLAGS)
if test "$TARGET_LINUX" = "true" -a "$static_nss" = ""
then
- tmp=`nm /usr/lib/libc.a | grep _nss_files_getaliasent_r`
+ tmp=`nm /usr/lib*/libc.a | grep _nss_files_getaliasent_r`
if test -n "$tmp"
then
STATIC_NSS_FLAGS="-lc -lnss_files -lnss_dns -lresolv"