summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorlars@mysql.com <>2005-04-19 11:09:54 +0200
committerlars@mysql.com <>2005-04-19 11:09:54 +0200
commit1bd55e471e3083c4fe86076ad9d0db27291196ec (patch)
tree82617d0fcbec77f54df35f27b2a89108ac86b497 /configure.in
parent8e0eb65f9aaa3dc5a4f713988e58190b82466cde (diff)
parentea9cbd3bb4bbcf08d193c6008fd93f4b8f7f7ff8 (diff)
downloadmariadb-git-1bd55e471e3083c4fe86076ad9d0db27291196ec.tar.gz
Merging 5.0->5.1
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 25 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 11bd87651da..afaaa57d344 100644
--- a/configure.in
+++ b/configure.in
@@ -41,7 +41,6 @@ sinclude(config/ac-macros/ha_blackhole.m4)
sinclude(config/ac-macros/ha_example.m4)
sinclude(config/ac-macros/ha_federated.m4)
sinclude(config/ac-macros/ha_innodb.m4)
-sinclude(config/ac-macros/ha_isam.m4)
sinclude(config/ac-macros/ha_ndbcluster.m4)
sinclude(config/ac-macros/ha_tina.m4)
sinclude(config/ac-macros/large_file.m4)
@@ -351,11 +350,30 @@ then
if echo $CXX | grep gcc > /dev/null 2>&1
then
- if $CXX -v 2>&1 | grep 'version 3' > /dev/null 2>&1
- then
- # Statically link the language support function's found in libsupc++.a
- LIBS="$LIBS -lsupc++"
- fi
+ GCC_VERSION=`gcc -v 2>&1 | grep version | sed -e 's/[[^0-9. ]]//g; s/^ *//g; s/ .*//g'`
+ case $SYSTEM_TYPE in
+ *freebsd*)
+ # The libsupc++ library on freebsd with gcc 3.4.2 is dependent on
+ # libstdc++, disable it since other solution works fine
+ GCC_VERSION="NOSUPCPP_$GCC_VERSION"
+ ;;
+ *)
+ ;;
+ esac
+ echo "Using gcc version '$GCC_VERSION'"
+ case "$GCC_VERSION" in
+ 3.4.*|3.5.*)
+ # Statically link the language support function's found in libsupc++.a
+ LIBS="$LIBS -lsupc++"
+ echo "Using -libsupc++ for static linking with gcc"
+ ;;
+ *)
+ # Using -lsupc++ doesn't work in gcc 3.3 on SuSE 9.2
+ # (causes link failures when linking things staticly)
+ CXXFLAGS="$CXXFLAGS -DUSE_MYSYS_NEW -DDEFINE_CXA_PURE_VIRTUAL"
+ echo "Using MYSYS_NEW for static linking with gcc"
+ ;;
+ esac
fi
fi
@@ -2735,7 +2753,7 @@ AC_CONFIG_FILES(Makefile extra/Makefile mysys/Makefile dnl
dbug/Makefile scripts/Makefile dnl
include/Makefile sql-bench/Makefile tools/Makefile dnl
server-tools/Makefile server-tools/instance-manager/Makefile dnl
- tests/Makefile Docs/Makefile Docs/Images/Makefile support-files/Makefile dnl
+ tests/Makefile Docs/Makefile support-files/Makefile dnl
support-files/MacOSX/Makefile mysql-test/Makefile dnl
netware/Makefile dnl
include/mysql_version.h dnl