summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@hundin.mysql.fi>2002-11-09 13:26:46 +0200
committerunknown <monty@hundin.mysql.fi>2002-11-09 13:26:46 +0200
commit212fe9d13ed51de7e858dedd2af71b115270af14 (patch)
treedc4bb2a2343e6494e99b3429fc1247fa2dd18281 /configure.in
parentb3a8b8bd193dc9b22b8d5bc28c894c49f6153647 (diff)
downloadmariadb-git-212fe9d13ed51de7e858dedd2af71b115270af14.tar.gz
Portability fixes for HP compiler and HPUX11
Docs/internals.texi: Added protocol information (needs to be converted to texi and merged with the old documentation) configure.in: Updates for HP compiler (cc) include/my_global.h: Add option to handle bugs in 'inline' for HP compiler libmysql/password.c: Portability fix (for HP compiler) mysys/hash.c: Portability fix (for HP compiler) mysys/my_static.c: Portability fix (for HPUX11) mysys/my_static.h: Portability fix (for HPUX11) mysys/my_tempnam.c: Portability fix (for HPUX11) sql/sql_analyse.cc: Fixed bug in decimal handling
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 61877c6b885..e4cf1d09dc5 100644
--- a/configure.in
+++ b/configure.in
@@ -934,6 +934,16 @@ case $SYSTEM_TYPE in
echo "Using --with-named-thread=-lpthread"
with_named_thread="-lpthread"
fi
+ # Fixes for HPUX 11.0 compiler
+ if test "$ac_cv_prog_gcc" = "no"
+ then
+ CFLAGS="$CFLAGS +DD64 -DHAVE_BROKEN_INLINE"
+ CXXFLAGS="$CXXFLAGS +DD64"
+ if "$with_debug" = "no"
+ then
+ CXXFLAGS="$CXXFLAGS +O2"
+ fi
+ fi
;;
*rhapsody*)
if test "$ac_cv_prog_gcc" = "yes"