summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorhf@deer.(none) <>2004-05-27 17:37:47 +0500
committerhf@deer.(none) <>2004-05-27 17:37:47 +0500
commit3a5e8d58cc0c804447d4ab7b83c432d4102a8bb3 (patch)
treefaac7d06fba2e2d566b8ca6772b17dd2f1873c1f /configure.in
parente27322d8264c56e2f86435c6f6b1f80dbb448f1c (diff)
parent6b42f932d6d01d8ed8a67a82da177e3a35dce66e (diff)
downloadmariadb-git-3a5e8d58cc0c804447d4ab7b83c432d4102a8bb3.tar.gz
Merge bk@192.168.21.1:/usr/home/bk/mysql-4.1
into deer.(none):/home/hf/work/mysql-4.1.ftr
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c00bbf60b60..e24965ad4d3 100644
--- a/configure.in
+++ b/configure.in
@@ -2133,6 +2133,31 @@ then
AC_DEFINE(HAVE_QUERY_CACHE)
fi
+AC_ARG_WITH(geometry,
+ [ --without-geometry Do not build geometry-related parts.],
+ [with_geometry=$withval],
+ [with_geometry=yes]
+)
+
+if test "$with_geometry" = "yes"
+then
+ AC_DEFINE(HAVE_SPATIAL)
+ AC_DEFINE(HAVE_RTREE_KEYS)
+fi
+
+AC_ARG_WITH(embedded_privilege_control,
+ [ --with-embedded-privilege-control
+ Build parts to check user's privileges.
+ Only affects embedded library.],
+ [with_embedded_privilege_control=$withval],
+ [with_embedded_privilege_control=no]
+)
+
+if test "$with_embedded_privilege_control" = "yes"
+then
+ AC_DEFINE(HAVE_EMBEDDED_PRIVILEGE_CONTROL)
+fi
+
AC_ARG_WITH(extra-tools,
[ --without-extra-tools Skip building utilites in the tools directory.],
[with_tools=$withval],