summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <hf@deer.(none)>2004-06-01 22:37:39 +0500
committerunknown <hf@deer.(none)>2004-06-01 22:37:39 +0500
commit7787dec6724ee8b4048f30e97a1d6d6b561eb12d (patch)
treeca5acfdebdd01f67435c581ee8916ac562d717b0 /configure.in
parentc0b6c9f7e9067d01d1a57e21e560033b6a489ba0 (diff)
parent7ec57e23fd036378df9eb0eeda6f6d7fe87f0aec (diff)
downloadmariadb-git-7787dec6724ee8b4048f30e97a1d6d6b561eb12d.tar.gz
Merge bk@192.168.21.1:/usr/home/bk/mysql-4.1
into deer.(none):/home/hf/work/mysql-4.1.ftr configure.in: Auto merged include/my_global.h: Auto merged sql/mysqld.cc: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0d38e6fa37b..01b030dbfd4 100644
--- a/configure.in
+++ b/configure.in
@@ -2132,6 +2132,31 @@ then
AC_DEFINE(HAVE_QUERY_CACHE)
fi
+AC_ARG_WITH(geometry,
+ [ --without-geometry Do not build geometry-related parts.],
+ [with_geometry=$withval],
+ [with_geometry=yes]
+)
+
+if test "$with_geometry" = "yes"
+then
+ AC_DEFINE(HAVE_SPATIAL)
+ AC_DEFINE(HAVE_RTREE_KEYS)
+fi
+
+AC_ARG_WITH(embedded_privilege_control,
+ [ --with-embedded-privilege-control
+ Build parts to check user's privileges.
+ Only affects embedded library.],
+ [with_embedded_privilege_control=$withval],
+ [with_embedded_privilege_control=no]
+)
+
+if test "$with_embedded_privilege_control" = "yes"
+then
+ AC_DEFINE(HAVE_EMBEDDED_PRIVILEGE_CONTROL)
+fi
+
AC_ARG_WITH(extra-tools,
[ --without-extra-tools Skip building utilites in the tools directory.],
[with_tools=$withval],