summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@hundin.mysql.fi>2002-10-29 21:59:03 +0200
committerunknown <monty@hundin.mysql.fi>2002-10-29 21:59:03 +0200
commitea3ffb9b3efedc03baf011467a0b84f394b1b19e (patch)
tree5eb822c41165cc8204269340f47d7a10e2b83d7f /configure.in
parent14cbecdc8b53b60dcaf101368bd3df3ae5a7c75e (diff)
downloadmariadb-git-ea3ffb9b3efedc03baf011467a0b84f394b1b19e.tar.gz
Added back old LARGEFILE handling
Fixed reference to freed memory in acl_init()/grant_init() Fixed possible memory leak. (Could only happen in very strange circumstances) Fixed bug in ALTER TABLE with BDB tables Updated mysql-test for valgrind Docs/manual.texi: ChangeLog acinclude.m4: Added back old LARGEFILE handling. (Needed to get MySQL to compile on Solaris 2.9 with gcc 3.x) configure.in: Added back old LARGEFILE handling. (Needed to get MySQL to compile on Solaris 2.9 with gcc 3.x) libmysqld/lib_sql.cc: Fixed reference to freed memory mysql-test/mysql-test-run.sh: Added option --valgrind mysys/Makefile.am: Removed warning when doing make sql/mysqld.cc: Free regexp memory on shutdown. read 'des' key files from data directory Fixed reference to freed memory in grant_init() sql/slave.cc: Fixed wrong printf() argument sql/sql_acl.cc: Fixed reference to freed memory sql/sql_acl.h: Fixed reference to freed memory sql/sql_base.cc: Fixed possible memory leak. (Could only happen in very strange circumstances) sql/sql_parse.cc: Updated arguments to grant_reload() sql/sql_table.cc: Fixed bug in ALTER TABLE with BDB tables sql/sql_yacc.yy: memset -> bzero
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 093b5aa8344..15adb09191e 100644
--- a/configure.in
+++ b/configure.in
@@ -671,7 +671,7 @@ else
AC_MSG_RESULT([no])
fi
-AC_SYS_LARGEFILE
+MYSQL_SYS_LARGEFILE
# Types that must be checked AFTER large file support is checked
AC_TYPE_SIZE_T