summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Widenius <monty@askmonty.org>2012-01-08 20:29:05 +0200
committerMichael Widenius <monty@askmonty.org>2012-01-08 20:29:05 +0200
commit629cdab80827e7ad6bb23f7c8dc20724eb87f4d9 (patch)
tree09881fe66fc7e71108aaf870cfd85758b8b46655 /configure.in
parent7e576c07103fc27e8d2a6a4f6d709426cc782f44 (diff)
downloadmariadb-git-629cdab80827e7ad6bb23f7c8dc20724eb87f4d9.tar.gz
Fixed compiler and test failures found by buildbot
configure.in: Added testing of STRNDUP (not found on solaris) mysql-test/include/wait_until_connected_again.inc: Also test for error 2005 (can happen on windows) mysql-test/include/wait_until_disconnected.inc: Also test for error 2005 (can happen on windows) mysql-test/suite/innodb_plugin/r/innodb_bug30423.result: Number of rows is not stable (found difference on Solaris) mysql-test/suite/innodb_plugin/t/innodb_bug30423.test: Number of rows is not stable (found difference on Solaris) plugin/auth_pam/auth_pam.c: Use internal strndup if it doesn't exist on system (solaris) Changed code so that it should also compile on solaris.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a592fb76a0e..9c3cbd283dc 100644
--- a/configure.in
+++ b/configure.in
@@ -2033,7 +2033,7 @@ dnl Checks for library functions.
AC_FUNC_ALLOCA
AC_PROG_GCC_TRADITIONAL
AC_TYPE_SIGNAL
-AC_CHECK_FUNCS(re_comp regcomp strdup)
+AC_CHECK_FUNCS(re_comp regcomp strdup strndup)
dnl Sun compilers have their own vis.h that is about something
dnl totally different. So, not to change the libedit source, we