summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <jimw@mysql.com>2005-08-24 15:54:23 -0700
committerunknown <jimw@mysql.com>2005-08-24 15:54:23 -0700
commitffc086e60a5cdf0632d7987ddda438a4991db8fa (patch)
tree2408b4ed8fd028e82c29e702dde98508806df16c /configure.in
parentce38e65bdcbb6c94d4599b03079bb4e7d41af82d (diff)
parent4b9431369611b4c3938288c0ef9eaa282f1bb417 (diff)
downloadmariadb-git-ffc086e60a5cdf0632d7987ddda438a4991db8fa.tar.gz
Merge mysql.com:/home/jimw/my/mysql-5.0-11680
into mysql.com:/home/jimw/my/mysql-5.0-clean configure.in: Auto merged sql/hostname.cc: Resolve conflict
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 5b3cfad6105..093ad166ff5 100644
--- a/configure.in
+++ b/configure.in
@@ -2446,7 +2446,7 @@ thread_dirs=
dnl This probably should be cleaned up more - for now the threaded
dnl client is just using plain-old libs.
-sql_client_dirs="libmysql strings regex client"
+sql_client_dirs="strings regex mysys sql/share libmysql client"
linked_client_targets="linked_libmysql_sources"
if test "$THREAD_SAFE_CLIENT" != "no"
@@ -2484,10 +2484,10 @@ then
AC_DEFINE([THREAD], [1],
[Define if you want to have threaded code. This may be undef on client code])
# Avoid _PROGRAMS names
- THREAD_LOBJECTS="thr_alarm.o thr_lock.o thr_mutex.o thr_rwlock.o my_pthread.o my_thr_init.o"
+ THREAD_LOBJECTS="thr_alarm.o thr_lock.o thr_mutex.o thr_rwlock.o my_pthread.o my_thr_init.o mf_keycache.o"
AC_SUBST(THREAD_LOBJECTS)
server_scripts="mysqld_safe mysql_install_db"
- sql_server_dirs="strings mysys dbug extra regex"
+ sql_server_dirs="strings dbug extra regex"
#
@@ -2595,7 +2595,6 @@ esac
# END of configuration for optional table handlers
#
sql_server_dirs="$sql_server_dirs myisam myisammrg heap vio sql"
-
fi
# IMPORTANT - do not modify LIBS past this line - this hack is the only way