summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Widenius <monty@askmonty.org>2010-01-15 20:06:18 +0200
committerMichael Widenius <monty@askmonty.org>2010-01-15 20:06:18 +0200
commitae8d0b378e472847053ff4c4f1612dd6bd3b1a47 (patch)
treea4a2fbfb3a469c42be3a9e5ba95da7d0912375f3 /configure.in
parentd121e6630519a66eec7c953ee0eae623f592ce87 (diff)
downloadmariadb-git-ae8d0b378e472847053ff4c4f1612dd6bd3b1a47.tar.gz
Fixed that we use same flags when testing for assembler as by makefiles.
Fixed bug in locking by triggers found by test case when compiling without query cache configure.in: Fixed that we use same flags when testing for assembler as by makefiles. sql/sql_yacc.yy: Fixed bug in locking by triggers found by test case when compiling without query cache The idea should be that triggers uses the same lock method (low_priority_locks...) as main tables.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 1 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 2aac45bf952..127e9ddb4a6 100644
--- a/configure.in
+++ b/configure.in
@@ -224,14 +224,6 @@ then
GXX="no"
fi
-if test "$ac_cv_prog_gcc" = "yes"
-then
- AS="$CC -c"
- AC_SUBST(AS)
-else
- AC_PATH_PROG(AS, as, as)
-fi
-
# Still need ranlib for readline; local static use only so no libtool.
AC_PROG_RANLIB
# We use libtool
@@ -688,7 +680,7 @@ AC_ARG_ENABLE(assembler,
AC_MSG_CHECKING(if we should use assembler functions)
# For now we only support assembler on i386 and sparc systems
-AM_CONDITIONAL(ASSEMBLER_x86, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "i386" && $AS strings/strings-x86.s -o checkassembler >/dev/null 2>&1 && test -f checkassembler && (rm -f checkassembler; exit 0;))
+AM_CONDITIONAL(ASSEMBLER_x86, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "i386" && $CCAS $CCASFLAGS -c strings/strings-x86.s -o checkassembler >/dev/null 2>&1 && test -f checkassembler && (rm -f checkassembler; exit 0;))
AM_CONDITIONAL(ASSEMBLER_sparc32, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "sparc")
AM_CONDITIONAL(ASSEMBLER_sparc64, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "sparcv9")
AM_CONDITIONAL(ASSEMBLER, test "$ASSEMBLER_x86_TRUE" = "" -o "$ASSEMBLER_sparc32_TRUE" = "")