summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexey Kopytov <Alexey.Kopytov@Sun.com>2009-12-22 19:23:13 +0300
committerAlexey Kopytov <Alexey.Kopytov@Sun.com>2009-12-22 19:23:13 +0300
commit12f364ece7663663cabdc29f106ca69af63fe4e7 (patch)
tree40437c602d2a9ddaa03a54742cec4884f0974253 /configure.in
parentd4f23f0cf6db38731a161c5c7b0b056fc67e5c02 (diff)
downloadmariadb-git-12f364ece7663663cabdc29f106ca69af63fe4e7.tar.gz
Backport of WL #2934: Make/find library for doing float/double
to string conversions and vice versa" Initial import of the dtoa.c code and custom wrappers around it to allow its usage from the server code. Conversion of FLOAT/DOUBLE values to DECIMAL ones or strings and vice versa has been significantly reworked. As the new algoritms are more precise than the older ones, results of such conversions may not always match those obtained from older server versions. This in turn may break compatibility for some applications. This patch also fixes the following bugs: - bug #12860 "Difference in zero padding of exponent between Unix and Windows" - bug #21497 "DOUBLE truncated to unusable value" - bug #26788 "mysqld (debug) aborts when inserting specific numbers into char fields" - bug #24541 "Data truncated..." on decimal type columns without any good reason"
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 402280392ba..ff6b486defb 100644
--- a/configure.in
+++ b/configure.in
@@ -375,6 +375,21 @@ case "$target_os" in
fi
;;
esac
+
+# The following is required for portable results of floating point calculations
+# on PowerPC. The same must also be done for IA-64, but this options is missing
+# in the IA-64 gcc backend.
+
+if test "$GCC" = "yes"
+then
+ case "$host_cpu" in
+ *ppc* | *powerpc*)
+ CFLAGS="$CFLAGS -mno-fused-madd"
+ CXXFLAGS="$CXXFLAGS -mno-fused-madd"
+ ;;
+ esac
+fi
+
AC_SUBST(CC)
AC_SUBST(CFLAGS)
AC_SUBST(CXX)
@@ -2236,7 +2251,7 @@ AC_FUNC_VPRINTF
AC_CHECK_FUNCS(alarm bcmp bfill bmove bsearch bzero \
chsize cuserid fchmod fcntl \
- fconvert fdatasync fesetround finite fpresetsticky fpsetmask fsync ftruncate \
+ fdatasync fesetround finite fpresetsticky fpsetmask fsync ftruncate \
getcwd gethostbyaddr_r gethostbyname_r getpass getpassphrase getpwnam \
getpwuid getrlimit getrusage getwd index initgroups isnan \
localtime_r gethrtime gmtime_r \