summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <serg@serg.mylan>2005-04-29 19:31:56 +0200
committerunknown <serg@serg.mylan>2005-04-29 19:31:56 +0200
commit927d747a21b7fe05a52074e511e75a600965c139 (patch)
tree5668aa9ce7b897640a509c918d6dc0f26852dc2d /configure.in
parente31358aecba242fc58ed30c81d71e46ff67ec4cb (diff)
parent90110b842979c65cf772d2c44167874995cc61dd (diff)
downloadmariadb-git-927d747a21b7fe05a52074e511e75a600965c139.tar.gz
Merge bk-internal:/home/bk/mysql-5.0
into serg.mylan:/usr/home/serg/Abk/mysql-5.0 configure.in: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in50
1 files changed, 18 insertions, 32 deletions
diff --git a/configure.in b/configure.in
index 5b1ceaabdbb..41f92788d7e 100644
--- a/configure.in
+++ b/configure.in
@@ -117,7 +117,6 @@ AC_SUBST(SAVE_LDFLAGS)
AC_SUBST(SAVE_CXXLDFLAGS)
AC_SUBST(CXXLDFLAGS)
-
#AC_ARG_PROGRAM # Automaticly invoked by AM_INIT_AUTOMAKE
AM_SANITY_CHECK
@@ -337,7 +336,7 @@ AC_SUBST(LD)
AC_SUBST(INSTALL_SCRIPT)
export CC CXX CFLAGS LD LDFLAGS AR
-
+echo "GXX: $GXX"
if test "$GXX" = "yes"
then
# mysqld requires -fno-implicit-templates.
@@ -345,36 +344,16 @@ then
# mysqld doesn't use run-time-type-checking, so we disable it.
CXXFLAGS="$CXXFLAGS -fno-implicit-templates -fno-exceptions -fno-rtti"
- # If you are using 'gcc' 3.0 (not g++) to compile C++ programs on Linux,
- # we will gets some problems when linking static programs.
- # The following code is used to fix this problem.
-
+ #CXX_VERNO=`echo $CXX_VERSION | sed -e 's/[[^0-9. ]]//g; s/^ *//g; s/ .*//g'`
+ echo "CXX: $CXX"
if echo $CXX | grep gcc > /dev/null 2>&1
then
- GCC_VERSION=`gcc -v 2>&1 | grep version | sed -e 's/[[^0-9. ]]//g; s/^ *//g; s/ .*//g'`
- case $SYSTEM_TYPE in
- *freebsd*)
- # The libsupc++ library on freebsd with gcc 3.4.2 is dependent on
- # libstdc++, disable it since other solution works fine
- GCC_VERSION="NOSUPCPP_$GCC_VERSION"
- ;;
- *)
- ;;
- esac
- echo "Using gcc version '$GCC_VERSION'"
- case "$GCC_VERSION" in
- 3.4.*|3.5.*)
- # Statically link the language support function's found in libsupc++.a
- LIBS="$LIBS -lsupc++"
- echo "Using -libsupc++ for static linking with gcc"
- ;;
- *)
- # Using -lsupc++ doesn't work in gcc 3.3 on SuSE 9.2
- # (causes link failures when linking things staticly)
- CXXFLAGS="$CXXFLAGS -DUSE_MYSYS_NEW -DDEFINE_CXA_PURE_VIRTUAL"
- echo "Using MYSYS_NEW for static linking with gcc"
- ;;
- esac
+ echo "Setting CXXFLAGS"
+ # If you are using 'gcc' 3.0 (not g++) to compile C++ programs on Linux,
+ # we will gets some problems when linking static programs.
+ # The following code is used to fix this problem.
+ CXXFLAGS="$CXXFLAGS -DUSE_MYSYS_NEW -DDEFINE_CXA_PURE_VIRTUAL"
+ echo "Using MYSYS_NEW for static linking with gcc"
fi
fi
@@ -2408,17 +2387,24 @@ then
compile_readline=yes
AC_DEFINE_UNQUOTED(USE_NEW_READLINE_INTERFACE, 1)
else
+ # Use system readline library
AC_LANG_SAVE
AC_LANG_CPLUSPLUS
MYSQL_CHECK_LIBEDIT_INTERFACE
MYSQL_CHECK_NEW_RL_INTERFACE
MYSQL_CHECK_READLINE_DECLARES_HIST_ENTRY
AC_LANG_RESTORE
- if [test "$mysql_cv_new_rl_interface" = "yes"] || [test "$mysql_cv_libedit_interface" = "no"]
+ if [test "$mysql_cv_new_rl_interface" = "yes"]
then
+ # Use the new readline interface
readline_link="-lreadline"
- else
+ elif [test "$mysql_cv_libedit_interface" = "yes"]; then
+ # Use libedit
readline_link="-ledit"
+ else
+ AC_MSG_ERROR([Could not find system readline or libedit libraries
+ Use --with-readline or --with-libedit to use the bundled
+ versions of libedit or readline])
fi
fi
fi