summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavi Arnaut <davi.arnaut@oracle.com>2010-07-20 14:44:29 -0300
committerDavi Arnaut <davi.arnaut@oracle.com>2010-07-20 14:44:29 -0300
commitd676c3ff0eef8613ac689df8ed07ecdd0a39817b (patch)
tree5cd22b1feaf7fd5459966139762af314803cdb12 /configure.in
parent17b9155f00f9f80c1c1f15bb98baebe21ac2a9e1 (diff)
downloadmariadb-git-d676c3ff0eef8613ac689df8ed07ecdd0a39817b.tar.gz
Bug#52514: mysql 5.1 do_abi_check does not compile w/ gcc4.5
due to GCC preprocessor change The problem is that newer GCC versions treats missing headers as fatal errors. The solution is to use a guard macro to prevent the inclusion of system headers when checking the ABI with the C Preprocessor. Reference: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=15638 http://gcc.gnu.org/bugzilla/show_bug.cgi?id=44836
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 1 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 0264c351b07..8dcdecf8ea2 100644
--- a/configure.in
+++ b/configure.in
@@ -444,16 +444,7 @@ if test "$GCC" != "yes" || expr "$CC" : ".*icc.*"
then
ABI_CHECK=""
else
- # Workaround GCC >= 4.5 - See Bug#52514
- case `$CC -dumpversion` in
- [[4-9]].[[5-9]]*)
- AC_MSG_WARN([ABI check disabled (GCC >= 4.5)])
- ABI_CHECK=""
- ;;
- *)
- ABI_CHECK="abi_check"
- ;;
- esac
+ ABI_CHECK="abi_check"
fi
AC_SUBST(ABI_CHECK)