summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <lenz@kallisto.local>2004-03-18 13:15:05 +0100
committerunknown <lenz@kallisto.local>2004-03-18 13:15:05 +0100
commit91c01dd9df02e54b50f315600b91e4781be927ae (patch)
treedd4dd73a41bfe541db2eb16717ec974709ee2420 /configure.in
parent93ca1bfac6d5607cba6775e20e8f302ad0faf9b8 (diff)
downloadmariadb-git-91c01dd9df02e54b50f315600b91e4781be927ae.tar.gz
- Use AC_CONFIG_SUBDIRS to invoke the InnoDB and BDB configure scripts
instead of calling them directly (WL#1521) - this also fixed a compile error with libtool-1.5.2 on FreeBSD (error: tag name "CXX" already exists)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 2 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index daf9cbde183..d95562a3791 100644
--- a/configure.in
+++ b/configure.in
@@ -2704,9 +2704,7 @@ then
/* ) rel_srcdir="$srcdir" ;;
* ) rel_srcdir="../../$srcdir" ;;
esac
- (cd $bdb/build_unix && \
- sh $rel_srcdir/$bdb/dist/configure $bdb_conf_flags) || \
- AC_MSG_ERROR([could not configure Berkeley DB])
+ AC_CONFIG_SUBDIRS($bdb/dist/configure)
dnl echo "bdb = '$bdb'; inc = '$bdb_includes', lib = '$bdb_libs'"
echo "END OF BERKELEY DB CONFIGURATION"
@@ -2745,25 +2743,7 @@ EOF
then
innodb_conf_flags=""
sql_server_dirs="$sql_server_dirs innobase"
- echo "CONFIGURING FOR INNODB"
- if test ! -d "innobase"; then
- # This should only happen when doing a VPATH build
- echo "NOTICE: I have to make the Innobase directory: `pwd`/innobase"
- mkdir "innobase" || exit 1
- fi
- rel_srcdir=
- case "$srcdir" in
- /* ) rel_srcdir="$srcdir" ;;
- * ) rel_srcdir="../$srcdir" ;;
- esac
- if test "x$enable_dependency_tracking" == xno
- then
- innodb_conf_flags=--disable-dependency-tracking
- fi
- (cd innobase && sh $rel_srcdir/innobase/configure --host=$host $innodb_conf_flags) \
- || AC_MSG_ERROR([could not configure INNODB])
-
- echo "END OF INNODB CONFIGURATION"
+ AC_CONFIG_SUBDIRS(innobase)
fi
#
# END of configuration for optional table handlers