summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <lenz@mysql.com>2002-12-23 13:33:55 +0100
committerunknown <lenz@mysql.com>2002-12-23 13:33:55 +0100
commitf0a3a93741724884b80f0eede0dac4074a24a25c (patch)
tree46f6bf4df57af4c8d4a812c2d8967e178de00ab2 /configure.in
parentb69d8f4a6f4a78f1ee61936ec440fa8ebb111319 (diff)
downloadmariadb-git-f0a3a93741724884b80f0eede0dac4074a24a25c.tar.gz
- fix CC_VERSION and CXX_VERSION for compilers that return multiple lines of
output for "--version" (e.g. gcc 3.x)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index f35b9fa7da9..6dd838bb5f2 100644
--- a/configure.in
+++ b/configure.in
@@ -130,7 +130,7 @@ AC_PROG_CXX
AC_PROG_CPP
# Print version of CC and CXX compiler (if they support --version)
-CC_VERSION=`$CC --version`
+CC_VERSION=`$CC --version | sed 1q`
if test $? -eq "0"
then
AC_MSG_CHECKING("C Compiler version");
@@ -138,7 +138,7 @@ then
else
CC_VERSION=""
fi
-CXX_VERSION=`$CXX --version`
+CXX_VERSION=`$CXX --version | sed 1q`
if test $? -eq "0"
then
AC_MSG_CHECKING("C++ compiler version");