summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorpetr/cps@mysql.com/owlet.local <>2006-11-01 16:47:40 +0300
committerpetr/cps@mysql.com/owlet.local <>2006-11-01 16:47:40 +0300
commit3ec542dfbdd08c13a6c33b07f7ddd9650c0e0ad8 (patch)
treee2642512c7a6f4cbdaa661730aca0413380e045e /configure.in
parentacaa584c5523753cab5b3a50ed3c95672b462541 (diff)
downloadmariadb-git-3ec542dfbdd08c13a6c33b07f7ddd9650c0e0ad8.tar.gz
Fix Bug #9191 "TIMESTAMP/from_unixtime() no longer accepts 2^31-1"
(4.1 version, with post-review fixes) The fix for another Bug (6439) limited FROM_UNIXTIME() to TIMESTAMP_MAX_VALUE which is 2145916799 or 2037-12-01 23:59:59 GMT, however unix timestamp in general is not considered to be limited by this value. All dates up to power(2,31)-1 are valid. This patch extends allowed TIMESTAMP range so, that max TIMESTAMP value is power(2,31)-1. It also corrects FROM_UNIXTIME() and UNIX_TIMESTAMP() functions, so that max allowed UNIX_TIMESTAMP() is power(2,31)-1. FROM_UNIXTIME() is fixed accordingly to allow conversion of dates up to 2038-01-19 03:14:07 UTC. The patch also fixes CONVERT_TZ() function to allow extended range of dates. The main problem solved in the patch is possible overflows of variables, used in broken-time representation to time_t conversion (required for UNIX_TIMESTAMP).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6cccb1bb90e..386d2349db9 100644
--- a/configure.in
+++ b/configure.in
@@ -1820,6 +1820,13 @@ then
AC_MSG_ERROR("MySQL needs a off_t type.")
fi
+dnl
+dnl check if time_t is unsigned
+dnl
+
+MYSQL_CHECK_TIME_T
+
+
# do we need #pragma interface/#pragma implementation ?
# yes if it's gcc 2.x, and not icc pretending to be gcc, and not cygwin
AC_MSG_CHECKING(the need for @%:@pragma interface/implementation)