summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <joerg@trift-lap.fambruehe>2007-07-16 19:06:11 +0200
committerunknown <joerg@trift-lap.fambruehe>2007-07-16 19:06:11 +0200
commit0cbe9a284cf535a6c438949d698e1e324074c2ca (patch)
tree3fabdb897297772c75b844f61c34fd09e6d7121f /configure.in
parent7d3cecca0ae25abdc2943e79410a19bdde5fff54 (diff)
parentf2cddbab175e57aee20a3e146e57c93c9626e681 (diff)
downloadmariadb-git-0cbe9a284cf535a6c438949d698e1e324074c2ca.tar.gz
Merge trift-lap.fambruehe:/MySQL/M50/mysql-5.0
into trift-lap.fambruehe:/MySQL/M50/push-5.0 configure.in: Auto merged sql/field.cc: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 1da39ac1aa3..843837b9348 100644
--- a/configure.in
+++ b/configure.in
@@ -100,14 +100,22 @@ AC_DEFINE_UNQUOTED([NDB_VERSION_STATUS], ["$NDB_VERSION_STATUS"],
# Canonicalize the configuration name.
-SYSTEM_TYPE="$host_vendor-$host_os"
-MACHINE_TYPE="$host_cpu"
+
+# Check whether --with-system-type or --without-system-type was given.
+AC_ARG_WITH(system-type,
+ [ --with-system-type Set the system type, like "sun-solaris10"],
+ [SYSTEM_TYPE="$withval"],
+ [SYSTEM_TYPE="$host_vendor-$host_os"])
+AC_ARG_WITH(machine-type,
+ [ --with-machine-type Set the machine type, like "powerpc"],
+ [MACHINE_TYPE="$withval"],
+ [MACHINE_TYPE="$host_cpu"])
AC_SUBST(SYSTEM_TYPE)
AC_DEFINE_UNQUOTED([SYSTEM_TYPE], ["$SYSTEM_TYPE"],
- [Name of system, eg solaris])
+ [Name of system, eg sun-solaris])
AC_SUBST(MACHINE_TYPE)
AC_DEFINE_UNQUOTED([MACHINE_TYPE], ["$MACHINE_TYPE"],
- [Machine type name, eg sun10])
+ [Machine type name, eg sparc])
# Detect intel x86 like processor
BASE_MACHINE_TYPE=$MACHINE_TYPE