summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGeorgi Kodinov <Georgi.Kodinov@Oracle.com>2010-08-16 18:16:07 +0300
committerGeorgi Kodinov <Georgi.Kodinov@Oracle.com>2010-08-16 18:16:07 +0300
commit5564e0837f8d6811acd6f8dc0369ec96dcab3c54 (patch)
tree94f7517b9264a7af5ea2dd14b146c7e10860363b /configure.in
parent37da201f2fde90fc952b22a75eb34274ac2c3494 (diff)
parent32edab6bfe4fada3adbf8688375600c8f911c82c (diff)
downloadmariadb-git-5564e0837f8d6811acd6f8dc0369ec96dcab3c54.tar.gz
merged mysql-5.5 into WL1054-5.5
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 1 insertions, 24 deletions
diff --git a/configure.in b/configure.in
index 80c436940a8..7f342f1ceda 100644
--- a/configure.in
+++ b/configure.in
@@ -1731,22 +1731,14 @@ then
fi
AC_ARG_WITH(debug,
- [ --with-debug Add debug code
- --with-debug=full Add debug code (adds memory checker, very slow)],
+ [AS_HELP_STRING([--with-debug], [Add debug code @<:@default=no@:>@])],
[with_debug=$withval],
[with_debug=no])
if test "$with_debug" = "yes"
then
- # Medium debug.
AC_DEFINE([DBUG_ON], [1], [Use libdbug])
CFLAGS="$DEBUG_CFLAGS $DEBUG_OPTIMIZE_CC -DSAFE_MUTEX $CFLAGS"
CXXFLAGS="$DEBUG_CXXFLAGS $DEBUG_OPTIMIZE_CXX -DSAFE_MUTEX $CXXFLAGS"
-elif test "$with_debug" = "full"
-then
- # Full debug. Very slow in some cases
- AC_DEFINE([DBUG_ON], [1], [Use libdbug])
- CFLAGS="$DEBUG_CFLAGS -DSAFE_MUTEX $CFLAGS"
- CXXFLAGS="$DEBUG_CXXFLAGS -DSAFE_MUTEX $CXXFLAGS"
else
# Optimized version. No debug
AC_DEFINE([DBUG_OFF], [1], [Don't use libdbug])
@@ -1782,21 +1774,6 @@ else
AC_MSG_RESULT([no])
fi
-# If we should allow error injection tests
-AC_ARG_WITH(error-inject,
- AC_HELP_STRING([--with-error-inject],[Enable error injection in MySQL Server]),
- [ with_error_inject=$withval ],
- [ with_error_inject=no ])
-
-if test $with_debug != "no"
-then
- if test "$with_error_inject" = "yes"
- then
- AC_DEFINE([ERROR_INJECT_SUPPORT], [1],
- [Enable error injection in MySQL Server])
- fi
-fi
-
AC_ARG_WITH([fast-mutexes],
AC_HELP_STRING([--with-fast-mutexes],
[Compile with fast mutexes (default is disabled)]),