summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2007-01-01 07:23:43 +0100
committerunknown <kent@mysql.com/kent-amd64.(none)>2007-01-01 07:23:43 +0100
commit4a090b1842b0ff0c136d9d180933ee2a55597135 (patch)
treeb38dc0f43e039dff21d34696be5d07435b5453c1 /configure.in
parentec08ea705871be703b55add6dbf5c07abfb76e4a (diff)
parent190a79c7f0e3f656bca932c213b3c48d5f4c8fd4 (diff)
downloadmariadb-git-4a090b1842b0ff0c136d9d180933ee2a55597135.tar.gz
Merge mysql.com:/home/kent/bk/tmp/mysql-4.1-build
into mysql.com:/home/kent/bk/tmp/mysql-5.0-build configure.in: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 49e295eeebb..3cf7327d185 100644
--- a/configure.in
+++ b/configure.in
@@ -2528,10 +2528,14 @@ AM_CONDITIONAL(HAVE_NETWARE, test "$netware_dir" = "netware")
export CC CXX CFLAGS CXXFLAGS LD LDFLAGS AR
ac_configure_args="$ac_configure_args CFLAGS='$CFLAGS' CXXFLAGS='$CXXFLAGS'"
-if test "$with_server" = "yes" -o "$THREAD_SAFE_CLIENT" != "no"
+if test "$with_server" != "no" -o "$THREAD_SAFE_CLIENT" != "no"
then
AC_DEFINE([THREAD], [1],
[Define if you want to have threaded code. This may be undef on client code])
+fi
+
+if test "$with_server" != "no"
+then
# Avoid _PROGRAMS names
THREAD_LOBJECTS="thr_alarm.o thr_lock.o thr_mutex.o thr_rwlock.o my_pthread.o my_thr_init.o mf_keycache.o"
AC_SUBST(THREAD_LOBJECTS)