summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tim@localhost.polyesthetic.msg>2000-08-10 11:21:42 -0400
committerunknown <tim@localhost.polyesthetic.msg>2000-08-10 11:21:42 -0400
commit07c1b843621db9f0e7b3e1ed06ceb1256180f04a (patch)
treee053b2ec45f60431341f2d3e3b3f500218c04f4e /configure.in
parentf5fa7fee9de0ed453960ada8efee6615cc77aa44 (diff)
downloadmariadb-git-07c1b843621db9f0e7b3e1ed06ceb1256180f04a.tar.gz
Automatically detect HAVE_INT_8_16_32.
Docs/manual.texi: - remove -DHAVE_INT_8_16_32 from recommended CFLAGS configure.in: - add test for int8 acconfig.h: - add HAVE_INT_8_16_32
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 24 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6a7c90aea8a..5550bcbe26e 100644
--- a/configure.in
+++ b/configure.in
@@ -580,6 +580,28 @@ LIBS_AFTER_SOCKET=$LIBS
LIBS="$LIBS_BEFORE_SOCKET $LIBS_SOCKET $LIBS_AFTER_SOCKET"
NON_THREADED_CLIENT_LIBS="$LIBS"
+AC_MSG_CHECKING([for int8])
+AC_TRY_RUN([
+#ifdef HAVE_STDLIB_H
+#include <stdlib.h>
+#endif
+
+#ifdef HAVE_STDDEF_H
+#include <stddef.h>
+#endif
+
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+
+int main()
+{
+ int8 i;
+ return 0;
+}
+], AC_DEFINE(HAVE_INT_8_16_32) AC_MSG_RESULT([yes]), AC_MSG_RESULT([no])
+)
+
#
# Some system specific hacks
#
@@ -662,8 +684,8 @@ case $SYSTEM_TYPE in
;;
*aix4.3*)
echo "Adding defines for AIX"
- CFLAGS="$CFLAGS -DHAVE_INT_8_16_32 -DUNDEF_HAVE_INITGROUPS"
- CXXFLAGS="$CXXFLAGS -DHAVE_INT_8_16_32 -DUNDEF_HAVE_INITGROUPS"
+ CFLAGS="$CFLAGS -DUNDEF_HAVE_INITGROUPS"
+ CXXFLAGS="$CXXFLAGS -DUNDEF_HAVE_INITGROUPS"
;;
esac