summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <cmiller@zippy.(none)>2006-07-12 11:39:12 -0400
committerunknown <cmiller@zippy.(none)>2006-07-12 11:39:12 -0400
commit4823bc50413d11a1f8329db9cde5bc5173d365c8 (patch)
tree04a65eb3a0f36e8e8318430e08af963e489249d6 /configure.in
parent019e221ca1a8be892e736f87e2b64df47ed91656 (diff)
parent4bfb28e22c81bd9e3086c170280746d9c3b7a7c2 (diff)
downloadmariadb-git-4823bc50413d11a1f8329db9cde5bc5173d365c8.tar.gz
Merge zippy.(none):/home/cmiller/mysql-4.1_bug18470
into zippy.(none):/home/cmiller/work/mysql/m50-maint--07C2P configure.in: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 48454a11309..be9ac7b4491 100644
--- a/configure.in
+++ b/configure.in
@@ -651,7 +651,7 @@ AC_ARG_ENABLE(assembler,
AC_MSG_CHECKING(if we should use assembler functions)
# For now we only support assembler on i386 and sparc systems
-AM_CONDITIONAL(ASSEMBLER_x86, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "i386")
+AM_CONDITIONAL(ASSEMBLER_x86, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "i386" && $AS strings/strings-x86.s -o checkassembler >/dev/null 2>&1 && test -f checkassembler && (rm -f checkassembler; exit 0;))
AM_CONDITIONAL(ASSEMBLER_sparc32, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "sparc")
AM_CONDITIONAL(ASSEMBLER_sparc64, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "sparcv9")
AM_CONDITIONAL(ASSEMBLER, test "$ASSEMBLER_x86_TRUE" = "" -o "$ASSEMBLER_sparc32_TRUE" = "")