summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <joerg@mysql.com>2005-04-20 20:38:57 +0200
committerunknown <joerg@mysql.com>2005-04-20 20:38:57 +0200
commitb6a4a2f41cb7aa04b59d8017070a69cd6f4c5082 (patch)
treeb82b278a25646c3778f5067f40248a6aa21d3700 /configure.in
parent677fbc7d4e34dff14aaf49efa114bc85aa986da1 (diff)
downloadmariadb-git-b6a4a2f41cb7aa04b59d8017070a69cd6f4c5082.tar.gz
Step 2 of the switch to support configuration with NPTL:
Define a new CPP symbol that the target OS is Linux, and use it where only the OS matters and not the threads Library. Until now, 'HAVE_LINUXTHREADS' was used to indicate "Target is Linux" in many places. When we support configuration with NPTL but no Linuxthreads, this misuse must cease. configure.in: Step 2 of the switch to support configuration with NPTL: Define a new CPP symbol that the target OS is Linux. Until now, 'HAVE_LINUXTHREADS' was used to indicate "Target is Linux" in many places. When we support configuration with NPTL but no Linuxthreads, this misuse must cease. include/my_global.h: Step 2 of the switch to support configuration with NPTL: Use the new 'TARGET_OS_LINUX' where only the OS matters and not the threads Library. mysys/thr_mutex.c: Step 2 of the switch to support configuration with NPTL: Use the new 'TARGET_OS_LINUX' where only the OS matters and not the threads Library. sql/stacktrace.c: Step 2 of the switch to support configuration with NPTL: Use the new 'TARGET_OS_LINUX' where only the OS matters and not the threads Library. sql/stacktrace.h: Step 2 of the switch to support configuration with NPTL: Use the new 'TARGET_OS_LINUX' where only the OS matters and not the threads Library. tools/mysqlmanager.c: Step 2 of the switch to support configuration with NPTL: Use the new 'TARGET_OS_LINUX' where only the OS matters and not the threads Library.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6650c0fc64a..f7a266eebec 100644
--- a/configure.in
+++ b/configure.in
@@ -412,6 +412,7 @@ then
MYSQLD_DEFAULT_SWITCHES="--skip-locking"
TARGET_LINUX="true"
AC_MSG_RESULT("yes");
+ AC_DEFINE([TARGET_OS_LINUX], [1], [Whether we build for Linux])
else
MYSQLD_DEFAULT_SWITCHES=""
TARGET_LINUX="false"