summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <bell@sanja.is.com.ua>2006-04-10 21:57:29 +0300
committerunknown <bell@sanja.is.com.ua>2006-04-10 21:57:29 +0300
commit9f705c55173ac32612b0b43726c9ad48bd279e3c (patch)
treeac37ee135b66257e3ba9ce95ff9cc9223accf083 /configure.in
parentbb5745cc600e5c234328d068908017a5868d2ecb (diff)
downloadmariadb-git-9f705c55173ac32612b0b43726c9ad48bd279e3c.tar.gz
Avoid trying to include <asm/atomic.h> when it doesn't work in C++
code. (Bug #13621) configure.in: Test whether atomic_add() and atomic_sub() are available in C++ code, since that is primarily where we will be using them.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index df4b0fbd5af..0445f7a05e9 100644
--- a/configure.in
+++ b/configure.in
@@ -830,6 +830,9 @@ AC_SUBST(WRAPLIBS)
if test "$IS_LINUX" = "true"; then
AC_MSG_CHECKING([for atomic operations])
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+
atom_ops=
AC_TRY_RUN([
#include <asm/atomic.h>
@@ -859,6 +862,8 @@ int main()
if test -z "$atom_ops"; then atom_ops="no"; fi
AC_MSG_RESULT($atom_ops)
+ AC_LANG_RESTORE
+
AC_ARG_WITH(pstack,
[ --with-pstack Use the pstack backtrace library],
[ USE_PSTACK=$withval ],