summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorbell@sanja.is.com.ua <>2006-04-10 21:57:29 +0300
committerbell@sanja.is.com.ua <>2006-04-10 21:57:29 +0300
commit5fe95af80446aa9028cc7839d422448398316a89 (patch)
treeac37ee135b66257e3ba9ce95ff9cc9223accf083 /configure.in
parentba424aacb0aedba7c878557ced6dbbdc4257e8b0 (diff)
downloadmariadb-git-5fe95af80446aa9028cc7839d422448398316a89.tar.gz
Avoid trying to include <asm/atomic.h> when it doesn't work in C++
code. (Bug #13621)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index df4b0fbd5af..0445f7a05e9 100644
--- a/configure.in
+++ b/configure.in
@@ -830,6 +830,9 @@ AC_SUBST(WRAPLIBS)
if test "$IS_LINUX" = "true"; then
AC_MSG_CHECKING([for atomic operations])
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+
atom_ops=
AC_TRY_RUN([
#include <asm/atomic.h>
@@ -859,6 +862,8 @@ int main()
if test -z "$atom_ops"; then atom_ops="no"; fi
AC_MSG_RESULT($atom_ops)
+ AC_LANG_RESTORE
+
AC_ARG_WITH(pstack,
[ --with-pstack Use the pstack backtrace library],
[ USE_PSTACK=$withval ],