summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorserg@sergbook.mylan <>2005-05-05 16:21:17 +0200
committerserg@sergbook.mylan <>2005-05-05 16:21:17 +0200
commit83dfc216a79114676a156b316496a8cb3c815959 (patch)
treea159160b54a9b49abb7b3833c961b61240f85878 /configure.in
parent25f44eab3137e10daac0d0c70ac8ada77880aa44 (diff)
downloadmariadb-git-83dfc216a79114676a156b316496a8cb3c815959.tar.gz
gcc 2.92 compatibility
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 1 insertions, 26 deletions
diff --git a/configure.in b/configure.in
index 8b0a0ddeb56..dfed8dda43e 100644
--- a/configure.in
+++ b/configure.in
@@ -336,32 +336,6 @@ AC_SUBST(LD)
AC_SUBST(INSTALL_SCRIPT)
export CC CXX CFLAGS LD LDFLAGS AR
-if test "$GXX" = "yes"
-then
- # mysqld requires -fno-implicit-templates.
- # Disable exceptions as they seams to create problems with gcc and threads.
- # mysqld doesn't use run-time-type-checking, so we disable it.
- CXXFLAGS="$CXXFLAGS -fno-implicit-templates -fno-exceptions -fno-rtti"
-
- CXX_VERNO=`echo $CXX_VERSION | sed -e 's/[[^0-9. ]]//g; s/^ *//g; s/ .*//g'`
- case "$CXX_VERNO" in
- 3.*)
- USE_MYSYS_NEW="-DUSE_MYSYS_NEW" # yassl needs it
- if echo $CXX | grep gcc > /dev/null 2>&1
- then
- # If you are using 'gcc' 3.0 (not g++) to compile C++ programs on Linux,
- # we will gets some problems when linking static programs.
- # The following code is used to fix this problem.
- CXXFLAGS="$CXXFLAGS $USE_MYSYS_NEW"
- AC_MSG_WARN([Using MYSYS_NEW for static linking with gcc])
- fi
- ;;
- *)
- USE_MYSYS_NEW=""
- ;;
- esac
- AC_SUBST(USE_MYSYS_NEW)
-fi
# Avoid bug in fcntl on some versions of linux
AC_MSG_CHECKING("if we should use 'skip-locking' as default for $target_os")
@@ -1730,6 +1704,7 @@ AC_TYPE_OFF_T
AC_STRUCT_ST_RDEV
AC_HEADER_TIME
AC_STRUCT_TM
+MYSQL_NEEDS_MYSYS_NEW
# AC_CHECK_SIZEOF return 0 when it does not find the size of a
# type. We want a error instead.
AC_CHECK_SIZEOF(char, 1)