summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <joreland@mysql.com>2005-01-19 07:23:20 +0100
committerunknown <joreland@mysql.com>2005-01-19 07:23:20 +0100
commit153160d1ffd9d118867c3e5c41474f435e5c981f (patch)
tree034ef16ea76331ac3b43df29bec04afd9b852e1c /configure.in
parentd2778647ae0679dff623a20419c302bad551e9aa (diff)
downloadmariadb-git-153160d1ffd9d118867c3e5c41474f435e5c981f.tar.gz
bug#7693 - ndb
when using shm transporter, set sigmask on each thread using pthread_sigmask configure.in: Add more functions needed for SHM ndb/src/common/portlib/NdbThread.c: 1) Create thread wrapper function 2) block SIGUSR1 #ifdef NDB_SHM_TRANSPORTER ndb/src/common/transporter/TransporterRegistry.cpp: (un)block SIGUSR1 #ifdef NDB_SHM_TRANSPORTER sql/ha_ndbcluster.cc: cast pointer to UintPtr before printout
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index b1b8b128f46..2d20a71f838 100644
--- a/configure.in
+++ b/configure.in
@@ -1924,7 +1924,7 @@ AC_CHECK_FUNCS(alarm bcmp bfill bmove bzero chsize cuserid fchmod fcntl \
pthread_key_delete pthread_rwlock_rdlock pthread_setprio \
pthread_setprio_np pthread_setschedparam pthread_sigmask readlink \
realpath rename rint rwlock_init setupterm \
- shmget shmat shmdt shmctl sigaction \
+ shmget shmat shmdt shmctl sigaction sigemptyset sigaddset \
sighold sigset sigthreadmask \
snprintf socket stpcpy strcasecmp strerror strnlen strpbrk strstr strtol \
strtoll strtoul strtoull tell tempnam thr_setconcurrency vidattr)
@@ -3098,7 +3098,10 @@ if test "$ac_cv_func_shmget" = "yes" &&
test "$ac_cv_func_shmat" = "yes" &&
test "$ac_cv_func_shmdt" = "yes" &&
test "$ac_cv_func_shmctl" = "yes" &&
- test "$ac_cv_func_sigaction" = "yes"
+ test "$ac_cv_func_sigaction" = "yes" &&
+ test "$ac_cv_func_sigemptyset" = "yes" &&
+ test "$ac_cv_func_sigaddset" = "yes" &&
+ test "$ac_cv_func_pthread_sigmask" = "yes"
then
AC_DEFINE([NDB_SHM_TRANSPORTER], [1],
[Including Ndb Cluster DB shared memory transporter])