summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2008-01-03 21:42:19 +0100
committerunknown <kent@mysql.com/kent-amd64.(none)>2008-01-03 21:42:19 +0100
commit9d63a0c2b6c8f119773318cb5f7c8cc32ca57036 (patch)
treeb7aa83730f7249dc96b4ea8aa736f6a72fd9c39e /configure.in
parent07aab86f5f1e25d25b1df2f43264048da86b509e (diff)
parent59ce093339fe0a63d133780bd808a006ac2e3d5b (diff)
downloadmariadb-git-9d63a0c2b6c8f119773318cb5f7c8cc32ca57036.tar.gz
Merge mysql.com:/home/kent/bk/build/mysql-4.0
into mysql.com:/home/kent/bk/build/mysql-4.1-build acinclude.m4: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 15 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 01b5734a3b0..1643426f827 100644
--- a/configure.in
+++ b/configure.in
@@ -205,7 +205,7 @@ CC_VERSION=`$CC --version | sed 1q`
esac
if test $? -eq "0"
then
- AC_MSG_CHECKING("C Compiler version");
+ AC_MSG_CHECKING("C Compiler version")
AC_MSG_RESULT("$CC $CC_VERSION")
else
CC_VERSION=""
@@ -220,7 +220,7 @@ CXX_VERSION=`$CXX --version | sed 1q`
esac
if test $? -eq "0"
then
- AC_MSG_CHECKING("C++ compiler version");
+ AC_MSG_CHECKING("C++ compiler version")
AC_MSG_RESULT("$CXX $CXX_VERSION")
else
CXX_VERSION=""
@@ -1369,7 +1369,7 @@ See the Installation chapter in the Reference Manual for more information.])
AC_MSG_RESULT("no need to check headers")
fi
- AC_MSG_CHECKING("for pthread_create in -lpthread");
+ AC_MSG_CHECKING("for pthread_create in -lpthread")
ac_save_LIBS="$LIBS"
LIBS="$LIBS -lpthread"
AC_TRY_LINK( [#include <pthread.h>],
@@ -1429,7 +1429,7 @@ then
then
AC_MSG_RESULT("yes")
else
- AC_MSG_ERROR([On SCO UNIX MySQL must be compiled with gcc. See the Installation chapter in the Reference Manual.]);
+ AC_MSG_ERROR([On SCO UNIX MySQL must be compiled with gcc. See the Installation chapter in the Reference Manual.])
fi
AC_MSG_RESULT("yes")
elif test -f /usr/local/lib/libpthread.a -o -f /usr/local/lib/libpthread.so
@@ -1445,7 +1445,7 @@ then
then
AC_MSG_RESULT("yes")
else
- AC_MSG_ERROR([On SCO UNIX MySQL must be compiled with gcc. See the Installation chapter in the Reference Manual.]);
+ AC_MSG_ERROR([On SCO UNIX MySQL must be compiled with gcc. See the Installation chapter in the Reference Manual.])
fi
AC_MSG_RESULT("yes")
# Hack for SCO UnixWare 7.1.x
@@ -1487,7 +1487,7 @@ then
AC_MSG_RESULT("no")
fi
else
- AC_MSG_ERROR([On SCO UNIX MySQL requires that the FSUThreads package is installed. See the Installation chapter in the Reference Manual.]);
+ AC_MSG_ERROR([On SCO UNIX MySQL requires that the FSUThreads package is installed. See the Installation chapter in the Reference Manual.])
fi
else
AC_MSG_RESULT("no")
@@ -1585,7 +1585,7 @@ else
if test "$with_mit_threads" = "no"
then
# pthread_create is in standard libraries (As in BSDI 3.0)
- AC_MSG_CHECKING("for pthread_create in -libc");
+ AC_MSG_CHECKING("for pthread_create in -libc")
AC_TRY_LINK(
[#include <pthread.h>],
[ (void) pthread_create((pthread_t*) 0,(pthread_attr_t*) 0, 0, 0); ],
@@ -1593,7 +1593,7 @@ else
AC_MSG_RESULT("$with_posix_threads")
if test "$with_posix_threads" = "no"
then
- AC_MSG_CHECKING("for pthread_create in -lpthread");
+ AC_MSG_CHECKING("for pthread_create in -lpthread")
ac_save_LIBS="$LIBS"
LIBS="$LIBS -lpthread"
AC_TRY_LINK(
@@ -1604,7 +1604,7 @@ else
if test "$with_posix_threads" = "no"
then
LIBS=" $ac_save_LIBS -lpthreads"
- AC_MSG_CHECKING("for pthread_create in -lpthreads");
+ AC_MSG_CHECKING("for pthread_create in -lpthreads")
AC_TRY_LINK(
[#include <pthread.h>],
[ pthread_create((pthread_t*) 0,(pthread_attr_t*) 0, 0, 0); ],
@@ -1614,7 +1614,7 @@ else
then
# This is for FreeBSD
LIBS="$ac_save_LIBS -pthread"
- AC_MSG_CHECKING("for pthread_create in -pthread");
+ AC_MSG_CHECKING("for pthread_create in -pthread")
AC_TRY_LINK(
[#include <pthread.h>],
[ pthread_create((pthread_t*) 0,(pthread_attr_t*) 0, 0, 0); ],
@@ -1895,7 +1895,7 @@ if test "$ac_cv_conv_longlong_to_float" != "yes"
then
AC_MSG_ERROR([Your compiler cannot convert a longlong value to a float!
If you are using gcc 2.8.# you should upgrade to egcs 1.0.3 or newer and try
-again]);
+again])
fi
fi
AC_CHECK_TYPES([sigset_t, off_t], [], [], [#include <sys/types.h>])
@@ -2047,7 +2047,7 @@ CFLAGS="$ORG_CFLAGS"
AC_CHECK_FUNC(fseeko,
[if test "$large_file_support" = no -a "$TARGET_LINUX" = "true";
then
- AC_MSG_ERROR("Found fseeko symbol but large_file_support is not enabled!");
+ AC_MSG_ERROR("Found fseeko symbol but large_file_support is not enabled!")
fi]
)
@@ -2740,7 +2740,7 @@ do
;;
*)
AC_MSG_ERROR([Charset '$cs' not available. (Available are: $CHARSETS_AVAILABLE).
- See the Installation chapter in the Reference Manual.]);
+ See the Installation chapter in the Reference Manual.])
esac
done
@@ -2917,7 +2917,7 @@ case $default_charset in
;;
*)
AC_MSG_ERROR([Charset $cs not available. (Available are: $CHARSETS_AVAILABLE).
- See the Installation chapter in the Reference Manual.]);
+ See the Installation chapter in the Reference Manual.])
esac
if test "$default_collation" = default; then
@@ -2942,7 +2942,7 @@ else
Collation $default_collation is not valid for character set $default_charset.
Valid collations are: $default_charset_collations.
See the Installation chapter in the Reference Manual.
- ]);
+ ])
fi
AC_DEFINE_UNQUOTED([MYSQL_DEFAULT_CHARSET_NAME], ["$default_charset"],